Bug 475450 - Can not show idle time
Can not show idle time
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pidgin (Show other bugs)
5.2.z
All Linux
low Severity medium
: rc
: ---
Assigned To: Warren Togami
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-09 04:47 EST by Suqin Huang
Modified: 2008-12-09 21:24 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-09 21:24:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Suqin Huang 2008-12-09 04:47:35 EST
Description of problem:
Can not show buddy's idle time

Version-Release number of selected component (if applicable):
pidgin-2.5.2-6.el5

How reproducible:
Always

Steps to Reproduce:
1. Launch pidgin and login msn.
2. Click Buddies->show to check "Idle times" and "Buddy details".
Make sure there are someone idle.
3. Observe the information of the buddies whose status are idle.
  
Actual results:
"Idle" is shown under nickname without idle time.

Expected results:
"Idle" is shown under nickname with idle time.

Additional info:
Comment 1 Mark Doliner 2008-12-09 15:05:38 EST
I don't believe the MSN protocol supports the display of idle times.  Do the official Windows Messenger clients support it?
Comment 2 Suqin Huang 2008-12-09 21:07:46 EST
It's my fault, Idle time display when I login Yahoo account.
Another question:
What is the function of "Minutes" in tool->I'dle mak'er->Set Account Idle Time.
No matter how many minutes I set, it always works the same. 
effects:
1. Buddy idle immediately when I Set Account Idle time.
2. Buddy unidle until I Unset Account Idle time.
3. Buddy's Idle time begin from 0 minute. (At first, I think the "$" Minutes I set is the supposed time, so the Idle time should begin with $)
These three effects always the same, where does "$" Minutes work?
Comment 3 Mark Doliner 2008-12-09 21:20:53 EST
"3. At first, I think the number of minutes I set is supposed to be the number of minutes that the Idle time begins with."

Yes, that is correct.  That is the intended behavior, however it is not supported by all protocols.  It should work correctly for AIM.  I think it does not work correctly for Yahoo because I think idle time on Yahoo ALWAYS starts at 0.  I don't know about other protocols.
Comment 4 Warren Togami 2008-12-09 21:24:40 EST
Suqin, I appreciate that you are testing it, but is it really necessary to write such reports about the tiniest minutiae like this?  Certainly we have bigger problems elsewhere that need testing and careful reporting.

Regarding Idle Maker, I always thought it was only a joke that is occasionally amusing to use, but of no practical value.

Since the original issue is not a bug, closing.

Note You need to log in before you can comment on or make changes to this bug.