Bug 475461 - openoffice.org-core requires liberation-fonts
openoffice.org-core requires liberation-fonts
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
10
All Linux
low Severity low
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-09 05:28 EST by Mark Knoop
Modified: 2008-12-09 06:25 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-09 05:54:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Knoop 2008-12-09 05:28:02 EST
Description of problem:
I don't like the Liberation Fonts, I don't want to use them, I particularly don't want to see them as the effective defaults in Firefox. The easiest way to achieve this was to uninstall them, but:

liberation-fonts >= 1.00 is needed by (installed) openoffice.org-core-1:3.0.0-9.10.fc10.x86_64

Version-Release number of selected component (if applicable):
openoffice.org-core-1:3.0.0-9.10.fc10

How reproducible:
100%

Steps to Reproduce:
1. Install openoffice.
2. Get liberation fonts everywhere.
3. Rub eyes.
  
Actual results:
Ugly fonts.

Expected results:
Bloated office software for occasional use only.

Additional info:
rpm -e --nodeps liberation-fonts seems to work with no ill-effects. OpenOffice works as well as it did before. Is this dependency really necessary?
Comment 1 Caolan McNamara 2008-12-09 05:54:39 EST
Without them .docs and .xls and .ppts will generally end up needing a different number of characters per line and different no of lines per page than they did in their original form under MS Office causing e.g. .ppt presentations to not fit on a slide and word documents with hard-coded formatting to page break in the wrong places. The purpose of Liberation is to be sufficiently metrically equivalent to give equivalent character and line positions as the MS equivalents (StarOffice for example includes a commercial set of fonts to fulfil the same purpose) Beauty of the actual glyphs is secondary :-) I feel that "the layout problem" is major enough, to warrant a hard requires
Comment 2 Mark Knoop 2008-12-09 06:25:03 EST
Hmm... so that's really a "Requires for one particular usage case involving documents in propriety formats." If it's important that page-breaks are the same in distributed documents then use a PDF.

> Beauty of the actual glyphs is secondary :-)

Indeed - I understand the purpose of the Liberation fonts. The problem is that when they are installed, there is no easy way to *not* use them, particularly for web browsing (short of ignoring all stylesheet font choices).

OO *doesn't* need the Liberation fonts to actually run - surely that's what requires are really for? Shame rpm doesn't have a "Suggests"...

Note You need to log in before you can comment on or make changes to this bug.