Bug 475498 - kdump: softlockup warnings when loading ahci.ko module on HP xw6800
kdump: softlockup warnings when loading ahci.ko module on HP xw6800
Status: CLOSED DUPLICATE of bug 475843
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Neil Horman
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-09 10:14 EST by Prarit Bhargava
Modified: 2008-12-15 10:51 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-15 10:51:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for 475418 (1.02 KB, patch)
2008-12-09 10:14 EST, Prarit Bhargava
no flags Details | Diff

  None (edit)
Description Prarit Bhargava 2008-12-09 10:14:12 EST
Created attachment 326329 [details]
Patch for 475418

Description of problem:

When dumping an xw6800 system softlockup warnings are seen when loading the ahci.ko module.

Version-Release number of selected component (if applicable): -125.el5 + patch from BZ 475418


How reproducible: 100%


Steps to Reproduce:
1. Boot kernel.
2. echo c > /proc/sysrq-trigger
  
Actual results:

ahci.ko module:

BUG: soft lockup - CPU#0 stuck for 10s! [exe:449]

Pid: 449, comm:                  exe
EIP: 0060:[<c104d1e9>] CPU: 0
EIP is at handle_IRQ_event+0x39/0x8c
 EFLAGS: 00000246    Tainted: G       (2.6.18.4 #2)
EAX: 0000000c EBX: c12e7480 ECX: c8e5b2c0 EDX: c8e43c7c
ESI: c8e5b2c0 EDI: 0000000c EBP: 00000000 DS: 007b ES: 007b
CR0: 8005003b CR2: b7fc5000 CR3: 01311000 CR4: 000006d0
 [<c104d2c0>] __do_IRQ+0x84/0xd6
 [<c104d23c>] __do_IRQ+0x0/0xd6
 [<c10074ce>] do_IRQ+0x99/0xc3
 [<c1005946>] common_interrupt+0x1a/0x20
 [<c102499d>] vprintk+0x2b4/0x2e8
 [<c101db0c>] __activate_task+0x4a/0x59
 [<c101881d>] io_apic_set_pci_routing+0x1b9/0x1c3
 [<c10249e9>] printk+0x18/0x8e
 [<c1123669>] acpi_pci_irq_enable+0x1a1/0x1ae
 [<c11535a3>] __driver_attach+0x0/0x6b
 [<c11aa72e>] pcibios_enable_device+0x14/0x16
 [<c10f0acc>] pci_enable_device_bars+0x21/0x2d
 [<c10f0af1>] pci_enable_device+0x19/0x37
 [<c10f0b6f>] pcim_enable_device+0x60/0x72
 [<c984617c>] ahci_init_one+0x6b/0x80e [ahci]
 [<c1031401>] call_usermodehelper_keys+0xc3/0xcf
 [<c103140d>] __call_usermodehelper+0x0/0x43
 [<c10f26d4>] pci_match_device+0x10/0xac
 [<c11535a3>] __driver_attach+0x0/0x6b
 [<c10f27bc>] pci_device_probe+0x36/0x57
 [<c11534f6>] driver_probe_device+0x42/0x92
 [<c11535e7>] __driver_attach+0x44/0x6b
 [<c1152f21>] bus_for_each_dev+0x37/0x59
 [<c1153441>] driver_attach+0x11/0x13
 [<c11535a3>] __driver_attach+0x0/0x6b
 [<c1152c29>] bus_add_driver+0x64/0xfd
 [<c10f28e1>] __pci_register_driver+0x3e/0x58
 [<c103d02c>] sys_init_module+0x1ae0/0x1c95
 [<c10094c6>] sys_mmap2+0x99/0xa3
 [<c1004f17>] syscall_call+0x7/0xb
 =======================
Expected results:

System should dump.

Additional info: Noticed by Prarit when testing 475418.  Issues appear to be unrelated.
Comment 1 Doug Chapman 2008-12-12 15:55:04 EST
It looks like this is a dup of bug 475987?
Comment 2 Neil Horman 2008-12-15 10:51:50 EST
concur, this is a dup of 475843.  closing.

*** This bug has been marked as a duplicate of bug 475843 ***

Note You need to log in before you can comment on or make changes to this bug.