Bug 475499 - Running Rosegarden crashes X server when using the xorg-x11-drv-ati driver
Running Rosegarden crashes X server when using the xorg-x11-drv-ati driver
Status: CLOSED DUPLICATE of bug 474973
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
10
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-09 10:24 EST by Mukund Sivaraman
Modified: 2018-04-11 10:07 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-22 16:32:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X server log file (105.47 KB, text/plain)
2009-02-08 12:41 EST, Olof Tångrot
no flags Details

  None (edit)
Description Mukund Sivaraman 2008-12-09 10:24:33 EST
Description of problem:

I am using Fedora 10 (x86_64) on a ThinkPad T60 laptop with ATI Technologies Inc Radeon Mobility X1400 rev 0 video chipset. There are several problems I face, one of which is that running Rosegarden (from the Fedora Everything repository) crashes the X server on startup when using the xorg-x11-drv-ati driver. xorg-x11-drv-radeonhd works OK, but this driver does not support 3D.

Other problems using xorg-x11-drv-ati have already been reported in other bugs (such as Adobe Flash plug-in not drawing correctly, very laggy browsing when using websites such as the BBC News front-page, etc.). These problems do not appear with the xorg-x11-drv-radeonhd driver.


Version-Release number of selected component (if applicable):

xorg-x11-drv-ati-6.9.0-61.fc10.x86_64
rosegarden4-1.6.1-2.fc9.x86_64


How reproducible:
Always

Steps to Reproduce:
1. Run Rosegarden
  
Actual results:
X server crashes

Expected results:
X server should not crash
Comment 1 Matěj Cepl 2008-12-19 11:19:38 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf (if you have one) whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Gianluca Sforna 2008-12-22 10:22:07 EST
duplicate of bug #474973 ?
Comment 3 Matěj Cepl 2008-12-22 16:32:30 EST
Most likely. Reporter, if you disagree, please, reopen this bug and provide information requested in the comment 1.

*** This bug has been marked as a duplicate of bug 474973 ***
Comment 4 Olof Tångrot 2009-02-08 12:41:38 EST
Created attachment 331249 [details]
X server log file
Comment 5 Matěj Cepl 2009-02-08 13:25:51 EST
(In reply to comment #4)
> Created an attachment (id=331249) [details]
> X server log file

Do you mean anything by this?

Note You need to log in before you can comment on or make changes to this bug.