Bug 475517 - DS9's menus too long
DS9's menus too long
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: ds9 (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Sergio Pascual
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-09 10:59 EST by Cong Ma
Modified: 2009-02-05 09:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-05 09:06:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cong Ma 2008-12-09 10:59:14 EST
Description of problem:
This may not count as a bug, but it is indeed an annoyance.

After the recent update (ds9-5.4-1.fc10), I found the "Region" menu excessively long. I can't get to the last items in the menu using a mouse pointer now. AFAIK the only way to access a menu item is to click on it using the mouse.

I don't know whether this is caused by additional items in the "Region" menu in the new version, because I can't remember what the whole menu used to be like...

The "Frame" menu has a similar problem.


Version-Release number of selected component (if applicable):
ds9-5.4-1.fc10.i386


How reproducible:
Always


Steps to Reproduce:
1. Start DS9 (5.4-1)
2. Click on the "Region" menu
3. Try going to the last rows of the dropped menu

 
Actual results:
Last rows can't be accessed.


Expected results:
All rows down to the bottom should be able to be clicked on.


Additional info:
I'm using a screen resolution of 1024x768. This is the highest possible for my graphic card/display.

I'm temporarily using a workaround: setting the default values of the "hidden" menu items via Edit -> Preferences each time I need to change them, and restart DS9. However, as you can see this doesn't really solve the problem... and productivity is hindered.

I guess this may be an upstream UI design problem. If you can't fix it, I understand.

Thank you very much for your time.
Comment 1 Sergio Pascual 2008-12-13 12:13:44 EST
Thanks for taking the time to report the bug.

Upstream ds9 still uses tcl/tk 8.4 and fedora's ds9 uses the native tcl/tk 8.5 
This means that the user interfaces aren't exactly equal. Namely the fonts are different and I can see that font size in fedora's ds9 is slightly bigger. This makes the menu problem worse.

Anyway, I can't get the whole Region menu, neither with upstream ds9 nor with fedora ds9. With upstream the last entry I can reach is "Save regions...", with fedora is "List regions..."

In my opinion, this is design problem of the user interface. The menu is just too long and it should have submenues.

Would you mind report your issue upstream?

Note You need to log in before you can comment on or make changes to this bug.