Bug 475555 - font glitches after an update of the radeon-driver
font glitches after an update of the radeon-driver
Status: CLOSED DUPLICATE of bug 466663
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-09 11:57 EST by flo
Modified: 2018-04-11 12:33 EDT (History)
3 users (show)

See Also:
Fixed In Version: xorg-x11-drv-ati-6.9.0-62.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-18 18:22:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of reproduction of the issue (26.88 KB, image/png)
2008-12-12 16:03 EST, Matěj Cepl
no flags Details
the xorg-log. was created for another purpose, but the font glitch was present, too (50 bytes, text/plain)
2008-12-13 10:33 EST, flo
no flags Details
my xorg.conf. everything except the synaptics section was created with Xorg -configure (5.03 KB, text/plain)
2008-12-13 10:35 EST, flo
no flags Details
/var/log/Xorg.0.log (53.67 KB, text/plain)
2008-12-16 16:44 EST, Matěj Cepl
no flags Details

  None (edit)
Description flo 2008-12-09 11:57:33 EST
Description of problem:
after a yum update, in which my ATI radeon-driver was updated, the font gets defaced. looks UGLY, you can't work with it
home.arcor.de/michael.jung11/schrift.png <--- there you can see how it looks like

Version-Release number of selected component (if applicable):


How reproducible:
i didn't try?

Steps to Reproduce:
1. update your radeon driver
2. wait some time (sometimes the font is fine, sometimes it isn't)
3. enjoy
  
Actual results:
glitched fonts

Expected results:
non-glitched fonts?
Comment 1 François Cami 2008-12-10 12:48:31 EST
Got the same problem on a FireGL V3100 (R400) after updating to
xorg-x11-drv-ati-6.9.0-61.fc10.x86_64 .

However, xorg-x11-drv-ati-6.9.0-62.fc10 fixed it for me.
It is available on Koji :
http://koji.fedoraproject.org/koji/buildinfo?buildID=73971

Flo, could you test -62 and report ?
Comment 2 flo 2008-12-12 12:13:07 EST
seems to work for me!
thanks :D
should be added to the updates
Comment 3 François Cami 2008-12-12 15:33:52 EST
Switching to Verified as a fix is pending.
Florian, thank you for confirming.
Comment 4 Matěj Cepl 2008-12-12 15:58:26 EST
No, this is not VERIFIED. Please, anything above ASSIGNED to maintainers. Actually this is not even properly bug triaged.

Reporter, please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf (if you have one) whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 5 Matěj Cepl 2008-12-12 16:03:17 EST
Created attachment 326775 [details]
Screenshot of reproduction of the issue
Comment 6 flo 2008-12-13 10:33:37 EST
Created attachment 326820 [details]
the xorg-log. was created for another purpose, but the font glitch was present, too
Comment 7 flo 2008-12-13 10:35:03 EST
Created attachment 326821 [details]
my xorg.conf. everything except the synaptics section was created with Xorg -configure
Comment 8 flo 2008-12-13 10:35:50 EST
sorry, but i cannot try all that with the glitching driver, because i need my system running, and with the newer driverversion everything works.
that's why, i do not want to start without my xorg.conf, too.

however, i created the xorg.conf with Xorg -configure, what seems to me like autodetection, and i only changed the synaptics section.

my graphics card got always recognized as ati radeon mobility 9800 to be handled with the radeon driver

btw: do i have to attach files to bugzilla, or can i post a link to it, too?
Comment 9 François Cami 2008-12-13 10:51:37 EST
Uncompressed files attached to bugzilla are much better than external links as they will stay in bugzilla forever.
Comment 10 Matěj Cepl 2008-12-16 16:44:34 EST
Created attachment 327172 [details]
/var/log/Xorg.0.log
Comment 11 Matěj Cepl 2008-12-16 17:03:26 EST
Reporter, could you please test with xorg-x11-drv-ati-6.9.0-62.fc10 from http://koji.fedoraproject.org/koji/buildinfo?buildID=73971 ? Does it help?
Comment 12 François Cami 2008-12-16 18:49:43 EST
Reporter is already running -62 and reported that this fixed the problem
(see comment https://bugzilla.redhat.com/show_bug.cgi?id=475555#c2 ).
Comment 13 François Cami 2008-12-18 18:22:36 EST

*** This bug has been marked as a duplicate of bug 466663 ***

Note You need to log in before you can comment on or make changes to this bug.