Bug 475558 - [LTC 5.4 FEAT] TTY terminal server over IUCV (userspace) [201735]
[LTC 5.4 FEAT] TTY terminal server over IUCV (userspace) [201735]
Status: CLOSED DUPLICATE of bug 477189
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: s390utils (Show other bugs)
5.4
s390x All
high Severity high
: alpha
: ---
Assigned To: Dan Horák
BaseOS QE
: OtherQA
Depends On: 477189
Blocks: 445204 475551
  Show dependency treegraph
 
Reported: 2008-12-09 12:00 EST by IBM Bug Proxy
Modified: 2009-06-20 04:45 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-29 16:18:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 50354 None None None Never

  None (edit)
Description IBM Bug Proxy 2008-12-09 12:00:55 EST
=Comment: #0=================================================
Emily J. Ratliff <ratliff@austin.ibm.com> - 
1. Feature Overview:
Feature Id:	[201735]
a. Name of Feature:	TTY terminal server over IUCV (userspace)
b. Feature Description
Implement client & server for a TTY terminal server under z/VM using IUCV as communication vehicle.
 
 This line item implements the terminal server running on a dedicated z/VM guest.
 The terminal server is a user space program that accepts connections via the normal network and
uses the AF_IUCV socket API to provide a console session to the Linux guests of the z/VM system that
are enabled for the IUCV console.

Additional Comments:	This is the userspace part for the kernel feature: 201734 - TTY terminal server
over IUCV - kernel

2. Feature Details:
Sponsor:	zSeries
Architectures:
s390x

Arch Specificity: Purely Arch Specific Code
Delivery Mechanism: Backport
Category:	RAS
Request Type:	Package - Feature from IBM
d. Upstream Acceptance:	Accepted
Sponsor Priority	1
f. Severity: High
IBM Confidential:	no
Code Contribution:	IBM code
g. Component Version Target:	s390tools 1.8.0

3. Business Case
Customer requirement to solve restriction to access to the Linux console for many Linux
administrators concurrently and they find the z/VM 3270 interface inadequate for the 200+ Linux
admins due to the inability to use common programs such as vi from this interface. The customer has
a requirement that the Linux system that needs to have its console accessed, will have its TCPIP
stack shutdown, so the solution can not involve an IP connection to that system IP stack.

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Hans-Georg Markgraf, mgrf@de.ibm.com, Boeblingen 49-7031-16-3978

Technical contact(s):
Gonzalo Muelas Serrano, gmuelas@de.ibm.com

IBM Manager:
Thomas Schwarz, t.schwarz@de.ibm.com
Comment 1 IBM Bug Proxy 2008-12-09 12:04:47 EST
Co-dependent on https://bugzilla.redhat.com/show_bug.cgi?id=475551
Comment 2 John Jarvis 2009-01-29 16:18:01 EST
closing as duplicate of BZ 477189 [LTC 5.4 FEAT] Pick up latest version of
s390-tools since we plan to rebase s390utils in RHEL 5.4

*** This bug has been marked as a duplicate of bug 477189 ***

Note You need to log in before you can comment on or make changes to this bug.