Bug 475576 - Can not set up a "move to folder ..." filter
Can not set up a "move to folder ..." filter
Status: CLOSED DUPLICATE of bug 474695
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
All Linux
medium Severity high
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-12-09 12:40 EST by Miloslav Trmač
Modified: 2008-12-09 13:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-12-09 13:00:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Miloslav Trmač 2008-12-09 12:40:07 EST
Version-Release number of selected component (if applicable):

Steps to Reproduce:
1. Receive a mail from a mailing list
2. Create a folder for the list
3. Right-click the mail, create a filter from mailing list.
4. In the "move to folder" action, chose your desired folder
5. Close all the dialogs, and press Ctrl-Y to test the filter

Actual results:
An error dialog / message in the status bar: (translated from Czech, roughly):
"Error filtering selected messages" Can not get folder ...: folder does not exist

Expected results:
Message moved to the target folder

Additional info:
The folder exists, moving mails to it manually works
Filters imported from older Evolution version work fine.

Looking at filters.xml, the new filter uses
          <value name="folder" type="folder">
            <folder uri="email://local@local/Lists/libvir"/>
whereas the older filters use:
          <value name="folder" type="folder">
            <folder uri="email://1219264640.7008.0@amilo/Lists/rh_friday"/>

[amilo is an old host name from wchich the older Evolution configuration was imported; this computer has a different host name.]
Comment 1 Milan Crha 2008-12-09 13:00:45 EST

*** This bug has been marked as a duplicate of bug 474695 ***

Note You need to log in before you can comment on or make changes to this bug.