Bug 475583 - openoffice.org prints PostScript source
openoffice.org prints PostScript source
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-09 13:00 EST by Michael Hampton
Modified: 2009-03-05 00:54 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-06 11:38:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Troubelshooter debug output (287.88 KB, text/plain)
2009-03-04 00:37 EST, Danny Ciarniello
no flags Details

  None (edit)
Description Michael Hampton 2008-12-09 13:00:47 EST
Description of problem:
When printing a document from openoffice.org (Writer in this case) the PostScript source is printed, rather than the document as it appears on screen.

Version-Release number of selected component (if applicable):
openoffice.org-writer-3.0.0-9.10.fc10.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Start OpenOffice.org Writer.
2. Load or write a document.
3. Print document.
  
Actual results:
PostScript source is printed in plain text, i.e.:
%!PS-Adobe-3.0
%%Creator: (OpenOffice.org 3.0)
etc.

Expected results:
PostScript should be interpreted and printed.

Additional info:
Printing to PDF and printing the resulting file from evince or Adobe Reader works normally. Printing from gedit works normally. CUPS test pages print normally.

This system was upgraded from Fedora 9, in which OOo printed normally.

This probably needs more info but I don't know what info you may need.
Comment 1 Caolan McNamara 2008-12-09 17:57:33 EST
Sounds truly remarkable. Not heard that one before. What about printing to a file as .ps rather than a .pdf, does that cause the same effect ? And what is the type of printer shown under system->administration->printing->right click->properties->make and model
Comment 2 David Tardon 2008-12-10 06:54:52 EST
I guess it be mismatched mimetype. Can you
1. attach /etc/cups/mime.types here
2. edit /etc/cups/cupsd.conf: set LogLevel to debug
3. restart CUPS (or run 'service cups reload' as root in terminal)
4. try again the printing
5. attach /var/log/cups/error-<todays date> here

You can also try to install cups-pdf and print to PDF printer: if the problem is between OpenOffice.org and a CUPS filter the resulting PDF file should contain PostScript source too.
Comment 3 Caolan McNamara 2008-12-11 18:17:57 EST
might help here to get the exact type of printer in use, i.e. what it says in
system->administration->printing->right_click->properties->make and model
Comment 4 Caolan McNamara 2008-12-16 06:52:44 EST
caolanm->twaugh: Heard of anything similar to this happening in F-10 that might give us a clue as how to reproduce it ?
Comment 5 Tim Waugh 2008-12-16 07:21:40 EST
Nope.  Getting the error_log, as suggested in comment #2, would be best for diagnosing it.

Incidentally, it might be easier to run the printing troubleshooter (System->Administration->Printing, then Help->Troubleshoot) to collect diagnostic information for this, rather than following the steps in comment #2.  Just select the printer you're using, then when it asks you to print a test page do so using OpenOffice.org and mark the job.  Then we'll get to see all the job attributes as well.
Comment 6 Caolan McNamara 2009-01-06 11:38:28 EST
printing works ok for me in F-10, feel free to re-open if you have additional information that could help reproduce this
Comment 7 Danny Ciarniello 2009-03-04 00:37:55 EST
Created attachment 333974 [details]
Troubelshooter debug output

I have also run into this problem.  I have a Brother HL4040CN and am using the Brother supplied CUPS driver (not foomatic).  OpenOffice is the only product that exhibits this problem.  Printing with other applications works fine.  

Here is the troubleshooter debug output from an OpenOffice print job.
Comment 8 Danny Ciarniello 2009-03-04 02:19:52 EST
A few observations.

Printing from OpenOffice worked just fine three days ago.  I don't know what has changed in the interim.

Printing works for root but not for a non-root user.

When printing from OpenOffice, I get this line in /var/log/messages:

localhost kernel: brcupsconfcl1[5387]: segfault at 626f6a20 ip 00000000626f6a20 sp 00000000ffb59e30 error 14

The segfault occurs for both root and non-root.  
The line appeared in the logs for the first time today.  
It does not appear when printing from other applications.
Comment 9 David Tardon 2009-03-04 02:53:35 EST
'D [03/Mar/2009:21:20:49 -0800] [Job 61] /usr/local/Brother/Printer/hl4040cn/cupswrapper/brlpdwrapper_hl4040cn: line 35: PPD=/etc/cups/ppd/HL4040CN.ppd: No such file or directory',

I think this could be the problem. Try to copy PPD file for the printer to /etc/cups/ppd/HL4040CN.ppd .

There is quite a lot of similar problems posted at http://www.cups.org/newsgroups.php?s21+gcups.general+T+Qpostscript; in most cases printing is OK from one application, but wrong (i.e. PS source is printed) from another.
Comment 10 Danny Ciarniello 2009-03-05 00:54:46 EST
I don't know why the 'No such file or directory' error occurred since the file is there.

The strange thing is that now, without changing anything, printing from OpenOffice is working again.  The only difference between now and yesterday is the time that has passed.  I hate "magical" fixes.

Note You need to log in before you can comment on or make changes to this bug.