Bug 475609 - kernel-xen ignores requested halt action
kernel-xen ignores requested halt action
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen (Show other bugs)
5.5
i386 Linux
low Severity medium
: rc
: ---
Assigned To: Xen Maintainance List
Martin Jenner
:
Depends On:
Blocks: 475006 514491
  Show dependency treegraph
 
Reported: 2008-12-09 14:05 EST by Vadym Chepkov
Modified: 2011-04-11 03:34 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-11 03:34:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vadym Chepkov 2008-12-09 14:05:23 EST
Kernel kernel-xen-2.6.18-92.1.18.el5 ignores requested halt action.

/sbin/halt -f powers off the system instead of halting it.
Comment 3 Andrew Jones 2010-06-23 09:53:49 EDT
Vadym,

what's the issue here? 'halt -f' should immediately halt the system without going through shutdown. Is that what you saw? Or something else?

Thanks,
Andrew
Comment 4 Vadym Chepkov 2010-06-23 10:29:41 EDT
Exactly, it "should immediately halt" it.
Instead, it powers it off, like it was called with -p switch.
halt and power off is a big difference.
Comment 5 Andrew Jones 2010-06-23 11:19:59 EDT
Testing 'halt -f' on all RHEL 5.5 guest configs 32/64-bit PV/HV it works for me, and so does issuing 'halt -f' from 64-bit dom0. Can you check to see if you still have the problem when using 5.5?

Andrew
Comment 6 Vadym Chepkov 2010-06-23 12:31:40 EDT
yes, it's still the case, that's why updated the version number to 5.5

When halt -f is issued in dom0 domain, instead of halting the server, 
it powers it off.
As a workaround I always create a /sbin/halt.local, like this:

#!/bin/bash

# See if this is a powerfail situation.
if [ -f /etc/apcupsd/powerfail ]; then

echo
echo "APCUPSD will now power off the UPS"
echo

/etc/apcupsd/apccontrol killpower

# Workaround for bz# 475006
while :
do
  echo Halt
  sleep 10
done
fi

If server was powered off, instead of halted, 
it will not come online when power is restored.
Comment 7 Andrew Jones 2010-06-24 04:04:42 EDT
And this only happens with xen kernels? bare-metal on the same hardware behaves as expected?
Comment 8 Vadym Chepkov 2010-06-24 09:43:33 EDT
Correct
Comment 9 Paolo Bonzini 2011-04-01 10:08:39 EDT
The UPS seems to be important as it doesn't reproduce here without.  Can you trigger it without one?
Comment 10 Vadym Chepkov 2011-04-10 20:17:14 EDT
It is importnat for power recovery, but UPS presence is not important.

It seems the problem doesn't exist in 5.6 kernel
Comment 11 Andrew Jones 2011-04-11 03:34:13 EDT
OK, as we haven't seen this issue reported broadly, and it seems to have gone away for the reporter as well with 5.6, then I believe it's safe to close this bug as current release.

Note You need to log in before you can comment on or make changes to this bug.