Bug 475615 - update unixODBC to latest 2.2.12 to solve compatibility with latest Oracle's proprietary driver
update unixODBC to latest 2.2.12 to solve compatibility with latest Oracle's ...
Status: CLOSED DUPLICATE of bug 497016
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: unixODBC (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Tom Lane
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-09 14:53 EST by Peter Lemenkov
Modified: 2013-07-02 23:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-13 15:55:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Lemenkov 2008-12-09 14:53:26 EST
Subj.

Newest Oracle proprietary odbc-driver requires unixODBC 2.2.12 while RHEL 5 still ships older version.
Comment 1 Tom Lane 2008-12-09 16:07:04 EST
Are you complaining about the 64-bit compatibility problems?  If so, 2.2.12 wouldn't fix it either.  We'd have to go to 2.2.14 and break ABI compatibility; which is unlikely to happen in RHEL5.
Comment 2 Peter Lemenkov 2008-12-09 16:11:59 EST
(In reply to comment #1)
> Are you complaining about the 64-bit compatibility problems?  If so, 2.2.12
> wouldn't fix it either.  We'd have to go to 2.2.14 and break ABI compatibility;
> which is unlikely to happen in RHEL5.

No, I'm complaining about message ""undefined symbol: SQLGetPrivateProfileStringW"" while trying to use 2.2.11 with official oracle odbc driver from Oracle.com. This issue was fixed in 2.2.12 only.

I thought it's known issue in RedHat's office :)
Comment 3 Tom Lane 2008-12-09 16:45:43 EST
I don't think it's exactly our problem if Oracle builds their driver against some other version of unixODBC than the one shipped with RHEL5.  You need to complain to them, not us.
Comment 4 Peter Lemenkov 2008-12-09 16:53:14 EST
(In reply to comment #3)
> I don't think it's exactly our problem if Oracle builds their driver against
> some other version of unixODBC than the one shipped with RHEL5.  You need to
> complain to them, not us.

OK, understood. RHEL 5 isn't compatible with Oracle's native odbc driver.
Comment 5 Shankar Unni 2009-03-02 21:20:07 EST
(In reply to comment #3)
> I don't think it's exactly our problem if Oracle builds their driver against
> some other version of unixODBC than the one shipped with RHEL5.

Any plans to refresh the version of unixODBC you guys ship with? unixODBC 2.2.11 was released in 2005. And 2.2.12 was released in 2006, so even that's getting pretty long in the tooth, but certainly a lot better than 2.2.11..
Comment 6 Shankar Unni 2009-03-02 21:21:15 EST
(Context: unixODBC 2.2.11 has some ugly problems; not just with the missing SQLGetPrivateProfileStringW(), etc., symbols, but also with ODBC batch APIs that basically don't work.  2.2.12 addresses most of those issues..
Comment 7 Tom Lane 2009-03-02 21:42:46 EST
We do currently ship 2.2.12 as part of the App Stack product.  I'm not sure we'd risk rebasing the version that's in core RHEL5 --- it's far from clear to me that 2.2.12 is 100% ABI-compatible, which is generally a "must" for RHEL5 updates.  2.2.14 is right out :-(
Comment 8 Jeremy West 2009-05-13 15:55:39 EDT

*** This bug has been marked as a duplicate of bug 497016 ***
Comment 9 Shankar Unni 2009-05-14 00:50:47 EDT
(In reply to comment #8)
> 
> *** This bug has been marked as a duplicate of bug 497016 ***  

Unfortunately that bug is private - can it please be made public so that we can track it?

Note You need to log in before you can comment on or make changes to this bug.