Bug 475638 - Problem with abnt2 keyboard and accent
Problem with abnt2 keyboard and accent
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
10
i686 Linux
low Severity high
: ---
: ---
Assigned To: Control Center Maintainer
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-09 16:21 EST by Marcus Alves Grando
Modified: 2009-02-03 15:57 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-03 15:57:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (90.96 KB, application/octet-stream)
2008-12-09 16:32 EST, Marcus Alves Grando
no flags Details

  None (edit)
Description Marcus Alves Grando 2008-12-09 16:21:36 EST
After install Fedora 10 and configure all things I saw that my system does not work anymore with Portuguese accents.

I configure correct system-config-keyboard with 'Brazillian (ABNT2)' and gnome-keyboard-properties to layouts = [br] and model = abnt2, but all gnome applications does no work correctly.

One strange thing is urxvt works fine and xev capture accents correctly.

Some idea to fix or another info? Thanks

I use LANG=en_US.UTF-8 but it's not important since another computer here works fine with the same conf and my Fedora 9 works too.

gconf and xprop outputs:

$ gconftool-2 -R /desktop/gnome/peripherals/keyboard
 click_volume = 0
 click = true
 rate = 100
 repeat = true
 bell_custom_file = (no value set)
 delay = 300
 remember_numlock_state = true
 bell_pitch = 400
 bell_mode = on
 bell_duration = 100
 /desktop/gnome/peripherals/keyboard/general:
  groupPerWindow = false
  layoutNamesAsGroupNames = true
  handleIndicators = false
  known_file_list = []
  disable_sysconfig_changed_warning = false
  defaultGroup = -1
  update_handlers = []
 /desktop/gnome/peripherals/keyboard/indicator:
  enabledPlugins = []
  secondary = 0
  showFlags = false
 /desktop/gnome/peripherals/keyboard/kbd:
  layouts = [br]
  model = abnt2
  options = [grp	grp:shift_caps_toggle]
 /desktop/gnome/peripherals/keyboard/preview:
  y = 108
  height = 648
  width = 864
  x = 144
 /desktop/gnome/peripherals/keyboard/host-sup-afu@46@wrk@46@terra@46@com@46@br:
  /desktop/gnome/peripherals/keyboard/host-sup-afu@46@wrk@46@terra@46@com@46@br/0:
   numlock_on = true
$ xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "evdev", "abnt2", "br", "", ""
_XKB_RULES_NAMES(STRING) = "evdev", "abnt2", "br", "", "grp:shift_caps_toggle"
Comment 1 Marcus Alves Grando 2008-12-09 16:32:44 EST
Created attachment 326407 [details]
Xorg.0.log
Comment 2 santiago angel 2008-12-16 03:01:20 EST
Same with spanish language and latin american keyboard.

On the live cd and in the initial boot everything works fine, but after a software update my system does not work anymore with Spanish accents.
Comment 3 Ray Strode [halfline] 2008-12-16 17:03:34 EST

*** This bug has been marked as a duplicate of bug 470153 ***
Comment 4 Marcus Alves Grando 2008-12-16 18:26:34 EST
It's not duplicate case of 470153. It's accent problem, totaly different.
Comment 5 santiago angel 2008-12-17 02:57:26 EST
RELATED https://bugzilla.redhat.com/show_bug.cgi?id=476615
Comment 6 Marcus Alves Grando 2009-02-03 15:57:13 EST
Fixed in update.

Note You need to log in before you can comment on or make changes to this bug.