Bug 475672 - F10:gnome-panel:clock-applet - PolicyKit broken authentication
F10:gnome-panel:clock-applet - PolicyKit broken authentication
Status: CLOSED DUPLICATE of bug 450304
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-09 18:34 EST by Daniele Orlando
Modified: 2008-12-10 12:46 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-10 12:46:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Replication demo (120.82 KB, image/jpeg)
2008-12-09 18:34 EST, Daniele Orlando
no flags Details

  None (edit)
Description Daniele Orlando 2008-12-09 18:34:11 EST
Created attachment 326430 [details]
Replication demo

System: Fedora 10

In Gnome 2.24, the clock applet is not able to authenticate the user using the PolicyKit window. There is no way to change the system data.

This is an issue inherited from Fedora 9, not yet fixed.
Comment 1 Daniele Orlando 2008-12-10 11:43:04 EST
I resolved the issue, modifying the PolicyKit rules:
"ALT+F2"/"polkit-gnome-authorization"
"org.gnome.clockapplet.mechanism.settime"
"Edit"/"Active Console"
I modified the value from the default wrong "Authentication" value to "Admin Authentication" value.

The same is valid for "org.gnome.clockapplet.mechanism.*".

A default consistent-working configuration of PolicyKit for the Clock-Applet maybe appreciated, especially by beginner users.

p.s.: Obviously this policy grant the right to modify the date and the time only to the Admin user and not to every one. I think this is a behaviour closer to the Fedora general policy:
gpk-update-viewer
system-config-services
and many others.
Every tool requires the admin password to modify a system general parameter, except the clock applet. This brakes in system consistence (IMHO).
Comment 2 Ray Strode [halfline] 2008-12-10 12:46:33 EST

*** This bug has been marked as a duplicate of bug 450304 ***

Note You need to log in before you can comment on or make changes to this bug.