Bug 475675 - [LTC 5.5 FEAT] cio_ignore entry in generic.prm for LPARs [201085]
[LTC 5.5 FEAT] cio_ignore entry in generic.prm for LPARs [201085]
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.5
s390x All
high Severity high
: alpha
: 5.6
Assigned To: David Cantrell
Release Test Team
: OtherQA
: 468172 511947 566264 (view as bug list)
Depends On: 463544
Blocks: 533941 554476 557597 481160
  Show dependency treegraph
 
Reported: 2008-12-09 18:40 EST by IBM Bug Proxy
Modified: 2011-01-24 18:36 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-12 23:14:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 50303 None None None Never

  None (edit)
Description IBM Bug Proxy 2008-12-09 18:40:23 EST
=Comment: #3=================================================
Emily J. Ratliff <ratliff@austin.ibm.com> - 
1. Feature Overview:
Feature Id:     [201085]
a. Name of Feature:     cio_ignore entry in generic.prm for LPARs
b. Feature Description
Currently there are customers complaining that when lots of devices are visible
to a Linux on System z system, although not all this devices are in used, they
consume precious resources and time, during installation, boot process and
normal work, in case of a device recovery situation, for example when uCode in
the machine or storage is updated or a HW card is changed on the fly.

We would like Red Hat to avoid this resources and performance issue and
document which implication has for the user during 
(1) installation, 
(2) boot and 
(3) normal work 
by making use of the cio_ignore kernel parameter to mask/unmask selected
devices and the capability to mask/unmask selected devices on the fly using the
proc interface.
For documentation about this kernel parameter and proc interface please read:
http://www.ibm.com/developerworks/linux/linux390/october2005_documentation.html
Device Drivers, Features, and Commands - SC33-8289-04
Chapter 33, pages 405-407

For details about previous work related to this request, please see: BZ/RIT34008/RIT118985.

2. Feature Details:
Sponsor:        zSeries
Architectures:
s390x

Arch Specificity: Purely Arch Specific Code
Affects Installer: Yes
Delivery Mechanism: Request Red Hat development assistance
Category:       zSeries
Request Type:   Installer - Enhancement from Distributor
d. Upstream Acceptance: No Code Required
Sponsor Priority        1
f. Severity: High
IBM Confidential:       no
Code Contribution:      no
g. Component Version Target:    n/a

3. Business Case
Allow customers to Install Linux on an LPAR configured to have potential
access to a huge number of devices.

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Hans-Georg Markgraf, mgrf@de.ibm.com, Boeblingen 49-7031-16-3978

Technical contact(s):
Gonzalo Muelas Serrano, gmuelas@de.ibm.com

IBM Manager:
Thomas Schwarz, t.schwarz@de.ibm.com
Comment 1 John Jarvis 2008-12-22 12:01:45 EST
IBM is signed up to test and provide feedback.
Comment 2 John Jarvis 2008-12-22 12:05:27 EST
IBM, this request needs to be broken down into clear, specific work items for it to be considered for inclusion in RHEL 5.4.  This request in its current state is far too vague.
Comment 3 IBM Bug Proxy 2009-01-09 05:51:54 EST
Hello Red Hat,

this feature should be consider as one, because otherwise if the work done during the installation is ignored for the boot process or tools dependent on devices it won't work.

As mentioned, is about masking the devices which are not used and unmasking them if they are needed.

The work items to work on are all which depend on devices to be present which could be masked/unmasked with cio_ignore, within:
1.- Installation
2.- Boot process
3.- Tools

If you would like to clone it for your different components it is fine with us, but please remember to consider all as one, since otherwise it won't work.

Thank you!
Comment 4 David Cantrell 2009-01-12 10:42:07 EST
*** Bug 468172 has been marked as a duplicate of this bug. ***
Comment 5 IBM Bug Proxy 2009-04-27 12:51:32 EDT
------- Comment From mgrf@de.ibm.com 2009-04-27 12:41 EDT-------
Hello Red Hat, Hi John,
What is the status regarding RHEL 5.4 acceptance for this feature?
Comment 6 John Jarvis 2009-04-27 14:36:28 EDT
This feature is denied for RHEL 5.4 due to a lack of resources.
Comment 7 IBM Bug Proxy 2009-04-28 08:10:45 EDT
------- Comment From gmuelas@de.ibm.com 2009-04-28 08:02 EDT-------
Hello Red Hat,

- if IBM takes over the QA (Test) responsibility for this feature, would you still have not resources to implement it?

- IBM believes that this it is a very interesting feature for the RHEL 5 System z customers, but since to implement this feature, RHEL would need changes in installer and tools to configure devices and we already in the 4th minor update, is Red Hat interested in this feature at all for future minor updates in RHEL 5, assuming you have the resources for future RHEL 5 minor updates?

Thank you!
Gonzalo Muelas Serrano.
Comment 8 Brad Hinson 2009-05-06 12:01:48 EDT
Using this BZ as RHEL 5 request.  Setting target to 5.5.
Comment 10 IBM Bug Proxy 2009-07-16 08:00:45 EDT
------- Comment From mgrf@de.ibm.com 2009-07-16 07:56 EDT-------
This request got a new feature BZ for RHEL 5.5 that is
LTC 54778  -  RHBZ 511947  [LTC 5.5 FEAT] cio_ignore entry in generic.prm for LPARs [201085]

Therefore closing this for RHEL 5.4 with "willnotfix" based on Red Hat reject
Comment 11 IBM Bug Proxy 2009-08-03 07:41:17 EDT
------- Comment From mgrf@de.ibm.com 2009-08-03 07:32 EDT-------
As agreed with John:

Re-open old RHEL 5.4 feature to request for inclusion into RHEL 5.5.
That is to have done discussions included in feature request

Note:
The new opened RHEL 5.5 feature BZ get closed
LTC 54778  -  RHBZ 511947  [LTC 5.5 FEAT] cio_ignore entry in generic.prm for
LPARs [201085]

------- Comment From mgrf@de.ibm.com 2009-08-03 07:40 EDT-------
*** Bug 54778 has been marked as a duplicate of this bug. ***
Comment 12 John Jarvis 2009-08-03 09:49:57 EDT
*** Bug 511947 has been marked as a duplicate of this bug. ***
Comment 13 Chris Lumens 2009-09-04 16:56:15 EDT
Can someone please provide a brief, clear description of what the problem is and what steps need to be taken in anaconda in order to address the issue?  I see a lot of comments here, but nothing really talking about the technical problem.  Patches are, of course, greatly appreciated.
Comment 14 IBM Bug Proxy 2009-10-26 09:05:20 EDT
------- Comment From gmuelas@de.ibm.com 2009-10-26 08:44 EDT-------
Sure:
Here is what I presented last Fr. on RHEL 5.5 eSDT meeting:
A Linux on System z system will in most cases see a lot more devices than it should be using (up to a current theoretical maximum of 262144 devices, in practice, 1000-4000 devices are common) Using the cio_ignore kernel parameter and /proc interface, this feature should mask the ccw devices which are not used and unmask them if they are needed. Note: When unmasking should be waited/verified that dev. is there (via sysfs) with a timeout (in case device does not exist).
More details about cio_ignore under:
??? Latest version of Device Drivers, Features, and Commands at:
http://www.ibm.com/developerworks/linux/linux390/development_documentation.html

This should be done during the installation and HW setup tools (like system-config-network) and persistent for each boot.

What is needed for this feature:
- Patch anaconda to:
By default mask all the devices except the console (0009) in generic.prm (default parmfile for installation)and propagate this kernel parameter to the zipl.conf (for boot)
Unmask and wait for appearance of devices needed (interactive and kickstart)[linuxrc.s390 already has support; backport for zfcp in anaconda]
- Patch mkinitrd (for root devices only) / initscripts (for all other devices) to:
Unmask and wait for appearance of devices needed which are enumerated in already existing config files such as modprobe.conf (options dasd_mod dasd=...), zfcp.conf (1st column) and ifcfg-* (SUBCHANNELS=...) where device numbers are listed (doing so automatically handles all cases of device configuration during installation, post-installation or manual editing of config files)
- Patch device configuration tools (at this moment only system-config-network) to:
Unmask and wait for appearance of devices as needed during user-interactive configuration

Denise will schedule a Tech. call when the developer who might be able to work on this feature have some time, since right now they are busy with RHEL 6... so probably will be around Jan. 2010.
Comment 15 David Cantrell 2010-01-13 16:14:51 EST
(In reply to comment #14)
> ------- Comment From gmuelas@de.ibm.com 2009-10-26 08:44 EDT-------
> Sure:
> Here is what I presented last Fr. on RHEL 5.5 eSDT meeting:
> A Linux on System z system will in most cases see a lot more devices than it
> should be using (up to a current theoretical maximum of 262144 devices, in
> practice, 1000-4000 devices are common) Using the cio_ignore kernel parameter
> and /proc interface, this feature should mask the ccw devices which are not
> used and unmask them if they are needed. Note: When unmasking should be
> waited/verified that dev. is there (via sysfs) with a timeout (in case device
> does not exist).
> More details about cio_ignore under:
> ??? Latest version of Device Drivers, Features, and Commands at:
> http://www.ibm.com/developerworks/linux/linux390/development_documentation.html
> 
> This should be done during the installation and HW setup tools (like
> system-config-network) and persistent for each boot.

We have this feature implemented in the RHEL-6 codebase, correct?  Or at least it's on the list of things to implement (there may be bugs at this point since we are not quite to beta 1 for RHEL-6).

The comments below discuss how this feature touches a number of other components, so this is actually a pretty big undertaking, especially for something like RHEL 5.

> What is needed for this feature:
> - Patch anaconda to:
> By default mask all the devices except the console (0009) in generic.prm
> (default parmfile for installation)and propagate this kernel parameter to the
> zipl.conf (for boot)
> Unmask and wait for appearance of devices needed (interactive and
> kickstart)[linuxrc.s390 already has support; backport for zfcp in anaconda]

This functionality exists in RHEL-6 anaconda as the following:
1) Patches for bug 475675
2) Patches for bug 463544
3) Steffen's rewritten linuxrc.s390
4) The recent patch to linuxrc.s390 to add dasd_settle() so we wait for DASD devices brought online to enter the "unformatted" or "online" state.

Based on what I see in bug 463544, we still need something like dasd_settle(), but for zFCP devices.  But maybe I'm wrong.  That may be there.  Likewise, the comments there also indicate we need something like dasd_settle() for network devices.  So while 463544 is in MODIFIED, it may bounce back as incomplete once again.

> - Patch mkinitrd (for root devices only) / initscripts (for all other devices)
> to:
> Unmask and wait for appearance of devices needed which are enumerated in
> already existing config files such as modprobe.conf (options dasd_mod
> dasd=...), zfcp.conf (1st column) and ifcfg-* (SUBCHANNELS=...) where device
> numbers are listed (doing so automatically handles all cases of device
> configuration during installation, post-installation or manual editing of
> config files)

These are bugs for two other components:  mkinitrd and initscripts.

> - Patch device configuration tools (at this moment only system-config-network)
> to:
> Unmask and wait for appearance of devices as needed during user-interactive
> configuration

This is a bug for system-config-network.

> Denise will schedule a Tech. call when the developer who might be able to work
> on this feature have some time, since right now they are busy with RHEL 6... so
> probably will be around Jan. 2010.    

At this point, I think this cio_ignore feature is still being actively worked in RHEL-6.  I would like to complete functionality there before we start backporting to RHEL-5.

Additionally, bugs need to be filed against mkinitrd, initscripts, and system-config-network for the changes they need with regard to this feature.  Anaconda should depend on the mkinitrd and initscripts bugs, the system-config-network bug is probably unnecessary to depend on, but maybe we should for completeness.

For now, I'm going to make this bug depend on 463544 since that's the main RHEL-6 bug for the anaconda part of this feature.  Someone should file bugs for this feature against mkinitrd, initscripts, and system-config-network.  If any of those are thrown out (especially mkinitrd), there's no point in expanding anaconda to support this feature in RHEL-5.
Comment 17 John Jarvis 2010-03-09 12:23:22 EST
*** Bug 566264 has been marked as a duplicate of this bug. ***
Comment 18 David Cantrell 2010-04-12 23:08:22 EDT
Based on the explanation in comment #15, I'm giving this a devel-nak.  We do not have the resources to implement this feature in RHEL 5.6 given the amount of work remaining for RHEL 6.0 (where we have implemented this feature).
Comment 19 RHEL Product and Program Management 2010-04-12 23:14:08 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.