Bug 475691 - F10:audacious:1.5.1 - Broken playing feature and multiple "Segmentation fault"
F10:audacious:1.5.1 - Broken playing feature and multiple "Segmentation fault"
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: audacious (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Ralf Ertzinger
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-09 20:34 EST by Daniele Orlando
Modified: 2009-06-26 22:47 EDT (History)
3 users (show)

See Also:
Fixed In Version: 1.5.1-6.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-26 22:45:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Audacious config file (3.26 KB, text/plain)
2008-12-09 20:35 EST, Daniele Orlando
no flags Details
Audacious log file (155.15 KB, text/plain)
2008-12-09 20:35 EST, Daniele Orlando
no flags Details

  None (edit)
Description Daniele Orlando 2008-12-09 20:34:46 EST
System: Fedora 10
Arch: x86_32

Upgrading from Fedora 9 to Fedora 10 I noticed a strange behaviour of Audacious; the new version of the player is not able to play audio file when it is lunched from the console:
[user@dragon ~]$ audacious song.ext
or when it's lunched from "Contextual Menu"/"Open With"/"Audacious" over a song.
In both cases, the music doesn't star and in both cases Audacious shows you a filesystem exploring window.

In addition to this issue, trying to command the player from the console, without an instance of Audacious already active, with any of these parameters:
-f
-p
-r
and similar
generates a "Segmentation fault" (without any previous error message).

I noticed this broken behaviours with different output-plugins (ALSA, Pulse) and with all the others plugins disabled.

I have not found any workaround to this issue.
This means that at the moment the player is completely unserviceable.

audacious-1.5.1-4.fc10.i386 (1.5.1-5.fc10 from updates-testing doesn't fix the issue)
audacious-libs-1.5.1-4.fc10.i386 (1.5.1-5.fc10 from updates-testing doesn't fix the issue)
audacious-plugin-fc-0.3-1.i386
audacious-plugins-1.5.1-2.fc10.i386
audacious-plugins-arts-1.5.1-2.fc10.i386
audacious-plugins-freeworld-1.4.5-2.fc10.i386
audacious-plugins-freeworld-aac-1.4.5-2.fc10.i386
audacious-plugins-freeworld-alac-1.4.5-2.fc10.i386
audacious-plugins-freeworld-mms-1.4.5-2.fc10.i386
audacious-plugins-freeworld-mp3-1.4.5-2.fc10.i386
audacious-plugins-freeworld-tta-1.4.5-2.fc10.i386
audacious-plugins-freeworld-wma-1.4.5-2.fc10.i386
audacious-plugins-metronome-1.5.1-2.fc10.i386
audacious-plugins-wavpack-1.5.1-2.fc10.i386
Comment 1 Daniele Orlando 2008-12-09 20:35:22 EST
Created attachment 326437 [details]
Audacious config file
Comment 2 Daniele Orlando 2008-12-09 20:35:57 EST
Created attachment 326438 [details]
Audacious log file
Comment 3 Eddie Lania 2008-12-28 14:48:51 EST
I am having the same trouble using audacious.i386 0:1.5.1-5.fc10.

I have googled for this problem. I found information about an upcoming fix: https://bugs.launchpad.net/bugs/291643
Comment 4 Eddie Lania 2009-05-01 12:21:08 EDT
Hello,

I'm running the Fedora 11 test release and the problem is still there. Why is this not solved yet?
Comment 5 Fedora Update System 2009-05-01 14:01:17 EDT
audacious-1.5.1-8.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/audacious-1.5.1-8.fc11
Comment 6 Dennis Jacobfeuerborn 2009-05-01 15:50:22 EDT
This is still broken for web links though. Going to http://kanzleramt.com/index.php?s_id=6&action=detail&id=215, clicking on an mp3 link and selecting audacious as application in firefox starts audacious but then then opens a file dialog instead of playing the file given.
Comment 7 Fedora Update System 2009-05-08 23:54:41 EDT
audacious-1.5.1-8.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update audacious'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-4313
Comment 8 Eddie Lania 2009-05-09 03:58:34 EDT
Installed audacious-1.5.1-8.fc11. Opening a .wav file starts audacious but then opens a file dialog instead of playing the file given.
Comment 9 Fedora Update System 2009-06-05 08:03:33 EDT
audacious-plugins-1.5.1-6.fc11,audacious-1.5.1-9.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/audacious-plugins-1.5.1-6.fc11,audacious-1.5.1-9.fc11
Comment 10 Fedora Update System 2009-06-05 08:11:07 EDT
audacious-plugins-1.5.1-6.fc10,audacious-1.5.1-9.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/audacious-plugins-1.5.1-6.fc10,audacious-1.5.1-9.fc10
Comment 11 Fedora Update System 2009-06-15 22:38:20 EDT
audacious-plugins-1.5.1-6.fc11, audacious-1.5.1-9.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update audacious-plugins audacious'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6438
Comment 12 Fedora Update System 2009-06-15 22:45:51 EDT
audacious-plugins-1.5.1-6.fc10, audacious-1.5.1-9.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update audacious-plugins audacious'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-6490
Comment 13 Fedora Update System 2009-06-26 22:44:59 EDT
audacious-plugins-1.5.1-6.fc11, audacious-1.5.1-9.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2009-06-26 22:47:11 EDT
audacious-plugins-1.5.1-6.fc10, audacious-1.5.1-9.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.