Bug 475714 - Mic input not forwarding to application in F10
Mic input not forwarding to application in F10
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
10
i686 Linux
low Severity high
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-09 22:19 EST by alauschke
Modified: 2009-04-24 11:14 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-24 11:14:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description alauschke 2008-12-09 22:19:02 EST
Description of problem:
I am new to Fedora, so bear with me, my description may sound very amateurish.

I upgraded from F9 to F10 with preupgrade. When making calls with Ekiga the other side cannot year my voice. I hear them just fine, but they cannot hear me at all. I decided to file a new bug report, because unlike 474477 there is nothing audible at all, not just very quiet.

I use PulseAudio, and maybe it's not related to that, maybe it's something else in F10, but the internet search I did points towards PA. Several people have written in several blogs that their mics don't work anymore, there MUST be something different in F10.

I tried the fix described on 
http://forums.fedoraforum.org/showthread.php?t=206868

but that didn't help either.

When I do cat /dev/dsp > /dev/dsp as user I always get maybe a second during which things seem to get recorded, and then it stops. It is not a continuous recording/playback.

When I have PulseAudio up or when I have the Volume Control up or when I have Ekiga up, I can hear myself, so there is feedback into my headphones (and my mic and cables are working), but it doesn't go out! When I do the echo test call in Ekiga I am supposed to hear myself not through feedback, but a play back from their server (to check the latency). Nothing comes back.

I can see the volume meters in PA move up and down just fine. So PA is recognizing my voice. I have the +20 db mic boost on, still to no avail (it was necessary to use on F9 -- it was working perfectly in F9!).
  
Actual results:
voice doesn't go out. Only feedback, but it doesn't leave Ekiga. (I can't even tell if the voice reaches Ekiga. I don't know where the feedback comes from, either from PA or from Volume Meter or from Ekiga)

Maybe I am missing a package? F10 has the well-known PackageKit problem, but that shouldn't really affect PA?

Expected results:
voice audio should get passed from PA to Ekiga and then go out.

Additional info:
my lspci:

00:00.0 Host bridge: ATI Technologies Inc Radeon Xpress 200 (RS480/RS482/RX480/RX482) Chipset - Host bridge (rev 01)
00:02.0 PCI bridge: ATI Technologies Inc RS480 PCI-X Root Port
00:06.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
00:13.0 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller
00:13.1 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller
00:13.2 USB Controller: ATI Technologies Inc IXP SB400 USB2 Host Controller
00:14.0 SMBus: ATI Technologies Inc IXP SB400 SMBus Controller (rev 11)
00:14.1 IDE interface: ATI Technologies Inc IXP SB400 IDE Controller
00:14.3 ISA bridge: ATI Technologies Inc IXP SB400 PCI-ISA Bridge
00:14.4 PCI bridge: ATI Technologies Inc IXP SB400 PCI-PCI Bridge
00:14.5 Multimedia audio controller: ATI Technologies Inc IXP SB400 AC'97 Audio Controller (rev 02)
00:14.6 Modem: ATI Technologies Inc SB400 AC'97 Modem Controller (rev 02)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility X700 (PCIE)
05:00.0 Ethernet controller: Broadcom Corporation NetLink BCM5789 Gigabit Ethernet PCI Express (rev 11)
06:02.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)
06:09.0 CardBus bridge: Texas Instruments PCIxx21/x515 Cardbus Controller
06:09.2 FireWire (IEEE 1394): Texas Instruments OHCI Compliant IEEE 1394 Host Controller
06:09.3 Mass storage controller: Texas Instruments PCIxx21 Integrated FlashMedia Controller
Comment 1 alauschke 2008-12-13 13:20:43 EST
I have filed the original bug report and would like to add the following information:

The new sectool outputs the following warning:

Warning, filesystem, Symbolic link "/var/lib/gdm/.pulse/9e93493ea561d21caee1ecf548ad9d0e:runtime" points to a non-existing file "/tmp/pulse-Y7BXDyp9ugPi".

Could that be related?
Comment 2 Joonas Sarajärvi 2008-12-28 14:58:42 EST
I can confirm this bug, too.

My hardware is a normal IBM Thinkpad T41 with a logitech USB sound set. The mic input from the headset is visible in pavucontrol's Input Devices tab, and Ekiga's recording can be set to be read from that stream. However, Ekiga seems not to hear only silence.

Also, for example, this:
arecord -v -d 10000 -t wav -D default foobar.wav

results in this:
Recording WAVE 'foobar.wav' : Unsigned 8 bit, Rate 8000 Hz, Mono
ALSA <-> PulseAudio PCM I/O Plugin
Its setup is:
  stream       : CAPTURE
  access       : RW_INTERLEAVED
  format       : U8
  subformat    : STD
  channels     : 1
  rate         : 8000
  exact rate   : 8000 (8000/1)
  msbits       : 8
  buffer_size  : 4000
  period_size  : 1000
  period_time  : 125000
  tstamp_mode  : NONE
  period_step  : 1
  avail_min    : 1000
  period_event : 0
  start_threshold  : 1
  stop_threshold   : 4000
  silence_threshold: 0
  silence_size : 0
  boundary     : 2097152000
arecord: pcm_read:1529: read error: Input/output error

I may be doing something wrong with arecord, but I think this should work fine, too.
Comment 3 Lennart Poettering 2009-04-23 17:56:30 EDT
Mr. Need a Real Name, so you say pavucontrol shows signal on your recording stream but ekiga doesn't get it?

Have you made sure that Ekiga uses the right audio device?

If you open pavucontrol's "Recording" tab, does it show the stream from ekiga? If you right click on it, can you move it to the right device?
Comment 4 Joonas Sarajärvi 2009-04-24 01:40:38 EDT
I've tested this again, and now Ekiga seems to work fine for me in F10.
Comment 5 alauschke 2009-04-24 09:54:12 EDT
I have noticed that a couple of weeks back things started working. So at some point in time bugs in F10 (which were not present in F9, because that was working fine all the time) must have fixed this. I don't know if this was a fix in PA or Ekiga or something else. It works now. (but I don't use Ekiga anymore, I have changed to Twinkle)
Comment 6 Lennart Poettering 2009-04-24 11:14:51 EDT
Ok, closing then.

Note You need to log in before you can comment on or make changes to this bug.