Bug 47576 - ATI RADEON VIVO improperly configured - blank or scrambled screen
ATI RADEON VIVO improperly configured - blank or scrambled screen
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-06 00:30 EDT by nextwaveo
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-31 05:04:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description nextwaveo 2001-07-06 00:30:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
On phone with tech support this AM.  Checked for option 'nodri" -- it's
there.  Checked the monitor refresh rates-- they're correct.   Could not
resolve the problem.  Text mode never a problem.  In GUI, grey screen,
black screen, scrambled screen, icons in reverse video....  By trying
different combinations of monitor/color depth you can get the screen to
work fine.  Then on reboot, same problem all over again.  

I've noticed a few similar bug reports with other Radeon cards.  This one
is
Radeon 64MB with standard vga out as well as video in/video out.  The
monitor is a GEM 19"  with sync rates of 30~95KHZ and 50~180KHZ,
Non-Interlaced 1600X1200, XGA, SVGA and VGA compatible.

Thanks for any suggestions

How reproducible:
Always

Steps to Reproduce:
1.startx - if scrambled or bad video log out
2. xconfigurator - try different monitor/color depths (probe /no probe it
doesn't seem to matter which)
3. If you get a good test image without freezing, exit config
4. Startx - picture is ok.  Logout and reboot.  9 out 10 times the video is
bad again	
	

Actual Results:  Erratic, but most often it takes several attempts to get a
viewable screen.  And then those settings don't seem to get saved (??)

Expected Results:  Once the settings are correct, I would expect them to be
there on reboot

Additional info:
Comment 1 nextwaveo 2001-07-09 22:15:15 EDT
I thought I might solve the problem by stepping up to XFree 4.1XX and I
installed the rpms from rpmfind.net (after failing miserably with the binaries
from xfree.org).   Close but no cigar. I was elated when XF86 -configure
actually correctly identified the card and even located its PCI address (which
didn't happen in my current version).  But when I tried starting up X... black
screen and complete lock-up.
It may be that I didn't setup the RPMS correctly (this is my third day of
exposure to Linux...) and maybe some of the other people who have similar
Radeon problems will have better luck with that as a solution--if you do, let me
know how you did it.
In the meantime, I need to get past this problem and do some work.  I don't want
to scrap the card (it works great in Windows).  If I buy an inexpensive generic
SVGA card, is it possible to configure Linux for 2 cards and just "ignore" the
Radeon for now until Red Hat comes up with a patch ?  Thanks for any suggestions
Comment 2 Mike A. Harris 2001-07-19 20:04:33 EDT
The Radeon 64 VIVO works for me quite well.  Is your card a
Radeon VE?  Please send the output of "lspci -v" and also "lspci -vn".
Comment 3 Mike A. Harris 2001-07-31 05:04:14 EDT
Still waiting for info.
Comment 4 Mike A. Harris 2001-08-14 03:35:55 EDT
Closing bug due to lack of interest and feedback 
from original submitter.  Radeon VIVO 64 AGP DDR works
well for me on a VIA board with K6300, an SMP Tyan
Thunder w/2x 1Ghz, and a 1Ghz Athlon with a VIA chipset
with updated Flash ROM.
Comment 5 Mike A. Harris 2001-08-14 03:36:34 EDT
Note, this is using XFree86 4.1.0-0.9.10

Note You need to log in before you can comment on or make changes to this bug.