Bug 475783 - Can't update rpcbind package while using ldap auth
Can't update rpcbind package while using ldap auth
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rpcbind (Show other bugs)
10
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Steve Dickson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-10 09:04 EST by maluyao
Modified: 2014-01-21 18:07 EST (History)
8 users (show)

See Also:
Fixed In Version: 0.2.0-2.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-16 03:28:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description maluyao 2008-12-10 09:04:34 EST
Description of problem:
Can't not update rpcbind package using yum command.

Version-Release number of selected component (if applicable):
Fedora 7/8/9/10

How reproducible:
By using ldap auth

Steps to Reproduce:
1.Install a new system
2.using ldap auth
3.yum update rpcbind
  
Actual results:

post scripts error

Expected results:


Additional info:

After use system auth (/etc/shadown), It can be updated.
Comment 1 seth vidal 2008-12-10 09:32:06 EST
Reassigning this bug to the correct package.
Comment 2 Steve Dickson 2008-12-10 10:45:15 EST
> post scripts error

What is the error?
Comment 3 Karl-Olov Serrander 2009-01-12 06:21:58 EST
I have the same problem with a nisclient on Fedora 10. Error message: Preparing...                ########################################### [100%]
error: %pre(rpcbind-0.1.7-1.fc10.x86_64) scriptlet failed, exit status 9
error:   install: %pre scriptlet failed (2), skipping rpcbind-0.1.7-1.fc10
Problem seems to be "/usr/sbin/userdel  rpc" in  %pre.
Changing /etc/nsswitch.conf: "passwd: files nis" to "passwd: files" makes %pre work, but that is not optimal if you have many nisclients to update.
Comment 4 Kasper Dupont 2009-02-02 02:19:53 EST
I experienced the same problem when running "yum update". Updating rpcbind failed with a script error. The userdel command was failing to delete the rpc user because there were two lines in /etc/shadow with the user name "rpc". On closer look I found that there were two copies of every user. The file had 70 lines, the first 35 were identical to the last 35. Removing the last 35 lines solved the problem.

userdel could be made a bit more resilient to this, but the real bug is that the contents of /etc/shadow were duplicated to begin with. I am not sure what produced the bad /etc/shadow. I suspect it was something happening earlier during the update.
Comment 5 Fedora Update System 2009-06-25 11:09:04 EDT
rpcbind-0.2.0-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/rpcbind-0.2.0-2.fc11
Comment 6 Fedora Update System 2009-06-30 17:34:39 EDT
rpcbind-0.2.0-2.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update rpcbind'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-7134
Comment 7 Fedora Update System 2009-07-16 03:28:17 EDT
rpcbind-0.2.0-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.