Bug 475789 - [RHEL5.4]: xm passes wrong device type for block-detach with TAP devices
[RHEL5.4]: xm passes wrong device type for block-detach with TAP devices
Status: CLOSED DUPLICATE of bug 484110
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.3
All Linux
high Severity high
: rc
: ---
Assigned To: Michal Novotny
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-10 09:43 EST by Daniel Berrange
Modified: 2014-02-02 17:36 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-11 07:39:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2008-12-10 09:43:47 EST
+++ This bug was initially created as a clone of Bug #473882 +++

There are two core problems with block detach

 - virsh & xm both pass 'type=vbd' even for TAP devices. This causes the wrong device controller to be used. This is the cause of the detach failure. This patch checks for the bogus type=vbd and fixes it

 - The /vm/$UUID/device/{vbd,tap}/$DEVID  path is not removed from xenstore, preventing a later re-attachment. This patch removes that path upon detach




This bug is to track the correct fixing of 'xm' command wrt to type=tap parameter.
Comment 2 Michal Novotny 2009-03-11 07:39:18 EDT
Well, I've been already solving bug #484110 which appears to be duplicate. If it's not please give me some information about information about the problem.

*** This bug has been marked as a duplicate of bug 484110 ***

Note You need to log in before you can comment on or make changes to this bug.