Bug 475808 - Browser creation failed: Did not receive a reply ...
Browser creation failed: Did not receive a reply ...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: openvrml (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Braden McDaniel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-10 10:53 EST by Ralf Corsepius
Modified: 2009-07-07 02:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-07 02:31:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Corsepius 2008-12-10 10:53:39 EST
Description of problem:

openvrml-player doesn't work on FC10 (cf. below)

Version-Release number of selected component (if applicable):
openvrml-player-0.17.10-1.0.fc10.x86_64

How reproducible:
Almost always (cf. below)

Steps to Reproduce:
1. run "openvrml-player"

  
Actual results:

After being started, nothing happens for several seconds, then an error message is being issued and openvrml-player come up with an empty window only displaying a text-entry.

$ openvrml-player
** (openvrml-player:3389): CRITICAL **: Browser creation failed: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

When selecting "Open" and pointing the file browser dialog to a *.wrl file, occasionally this happens aft:
**
ERROR:openvrml-player/curlbrowserhost.cpp:345:void openvrml_player_curl_browser_host_load_url(OpenvrmlPlayerCurlBrowserHost*, const char*): assertion failed: (host->priv->browser)


Expected results:
function.

Additional info:
* This issue seems to start after launching openvrml-player for a second time after system bootup.
* I would not want to exclude this issue being related to the current dbus mess up in Fedora 10.
Comment 1 Colin Walters 2008-12-10 12:28:13 EST
Does one of these programs use a system service?
Comment 2 Braden McDaniel 2008-12-10 14:02:25 EST
openvrml-player uses openvrml-xembed. openvrml-xembed is a system service.
Comment 3 Ralf Corsepius 2008-12-19 03:59:45 EST
After the dbus package has been reverted, this issue seems to have vanished.

=> IMO, a clear case of dbus mess-up.

Any dbus tracker bug available? Reassign this BZ to dbus?
Comment 4 Bruce Brackbill 2008-12-28 11:32:12 EST
I also see this bug

openvrml-gl-0.17.10-1.0.fc9.i386
openvrml-xembed-0.17.10-1.0.fc9.i386
openvrml-player-0.17.10-1.0.fc9.i386
openvrml-0.17.10-1.0.fc9.i386
Comment 5 Braden McDaniel 2009-07-07 02:31:21 EDT
Looks like this was probably D-Bus bustage.

Anyone still observing these symptoms, please file a new bug.

Note You need to log in before you can comment on or make changes to this bug.