Bug 475863 - wg111v2 wifi card doesn't work (netgear)
wg111v2 wifi card doesn't work (netgear)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-10 15:41 EST by Nicolas R.
Modified: 2009-04-14 13:56 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-14 13:56:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas R. 2008-12-10 15:41:17 EST
Description of problem:
The wifi card netgear wg111v2 (usb) doesn't work correctly. Networks are detected, but with above 15% of power (normally 90%), after somes seconds after connecting to network, the connexion fall down. 

This usb card use rtl8187 module. She works better in old kernel (like kernel on live cd F9).


Steps to Reproduce:
1. connect to network with wg111v2
2. go to a website, after somes seconds the signal is lost.
Comment 1 Andrew Kornak 2009-02-03 04:29:24 EST
Alfa (awus036h) in my case has low quality yet detects all networks in the area.
Cannot associate with any network because of low power. Windows gives me about 70 to 80 percent quality versus 13 percent using rtl8187 on Linux.
Comment 2 John W. Linville 2009-02-25 10:13:51 EST
What kernel version are you using?
Comment 3 Nicolas R. 2009-02-25 10:49:01 EST
I'm using the last kernel available : 2.6.27.15-170.2.24.fc10.x86_64
Comment 4 John W. Linville 2009-02-25 11:04:37 EST
Please give the one a try:

   http://koji.fedoraproject.org/koji/buildinfo?buildID=83870

Does it work any better for you?
Comment 5 Andrew Kornak 2009-03-23 16:22:09 EDT
I tried this kernel and the power improves to about 60 percent but it is 80 percent on the windows side. I can get 95 percent only if the network is about 10 feet away from the AP. I also tried 2.6.29-0.67.rc8.git4.fc10.i686 with the same result. I am willing to test another kernel or driver if necessary.
Comment 6 John W. Linville 2009-04-14 13:56:09 EDT
I'm sorry we aren't matching the performance of the Windows driver, but that is to be expected given the that the driver is essentially reverse-engineered (actually rewritten using vendor sources as a hardware spec).  Comment 5 sounds pretty good to me, so I'm closing on that basis.

Note You need to log in before you can comment on or make changes to this bug.