Bug 475886 - no ssh agent when logging in with AutomaticLogin
no ssh agent when logging in with AutomaticLogin
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-10 17:09 EST by Jonathan Kamens
Modified: 2015-01-14 18:22 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-21 22:19:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2008-12-10 17:09:29 EST
When gdm is configured in /etc/gdm/custom.conf with AutomaticLogin to log in a particular user automatically, then when that user logs in there isn't any SSH agent running for him/her.  I don't know of any way to start one up, either, because the agent environment variables would have to be the same for all processes in the session, so they would have to be set within gnome-session before it starts any child processes.
Comment 1 Ray Strode [halfline] 2008-12-10 17:30:25 EST
gnome-session doesn't use ssh-agent.  gnome-keyring-daemon provides the same functionality, I believe.

Does it work okay without ssh-agent for you?
Comment 2 Jonathan Kamens 2008-12-10 17:33:00 EST
I'm not talking about the program ssh-agent in particular.  I'm talking about something providing SSH agent functionality.  After automatic login, "ssh-agent -l" doesn't work, which means that there's nothing providing SSH agent functionality.  If it's supposed to be gnome-keyring-daemon doing it, then apparently gnome-keyring-daemon isn't started properly during automatic login.
Comment 3 Ray Strode [halfline] 2008-12-10 17:58:46 EST
seems like bug 475885 and this one probably have the same root cause.
Comment 4 Matthias Clasen 2008-12-13 14:51:25 EST
Is gnome-keyring-daemon running after your automatic login ?
Comment 5 Jonathan Kamens 2008-12-13 23:12:38 EST
Yes, gnome-keyring-daemon is there.
Comment 6 Jonathan Kamens 2008-12-15 09:24:50 EST
It looks like I was wrong about automatic login being relevant to this.  I could have sworn that before, when I logged out of the automatic login session and logged back in, SSH agent functionality came back, but now, with current packages from rawhide as of this morning, I don't have access to an agent whether I'm logged in automatically or by hand.  And yes, gnome-keyring-daemon is still running.

Oddly, I see this in my ~/.xsession-errors file:

GNOME_KEYRING_SOCKET=/tmp/keyring-WkkiLF/socket
SSH_AUTH_SOCK=/tmp/keyring-WkkiLF/ssh

Additional weirdness... The GNOME_KEYRING_SOCKET variable *is* set in my environment, and if I execute the SSH_AUTH_SOCK setting by hand and export it, then ssh-add -l works again.

So perhaps something is exporting GNOME_KEYRING_SOCKET but forgetting to export SSH_AUTH_SOCK?  Just a guess, probably wrong, but I thought I'd throw it out there.
Comment 7 Ray Strode [halfline] 2008-12-15 13:33:21 EST

*** This bug has been marked as a duplicate of bug 476300 ***
Comment 8 Jonathan Kamens 2008-12-19 09:43:08 EST
I was right!  I downgraded to gnome-keyring-2.25.1-1.fc11, and that restores SSH agent functionality when I log in manually, but SSH agent functionality is still missing when I'm logged in through automatic login.  That means that this bug isn't a duplicate of 476300.
Comment 9 Jonathan Kamens 2008-12-21 22:19:12 EST
Whatever was done to fix bug 476300 apparently fixed this as well, or some other fix was made but in any case it's no longer an issue in gnome-keyring-2.5.2-3.fc11.

Note You need to log in before you can comment on or make changes to this bug.