Bug 475912 - Bootup drops into text mode (--hide-splash) upon detection of non luks encrypted filesystems.
Bootup drops into text mode (--hide-splash) upon detection of non luks encryp...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11Blocker/F11FinalBlocker
  Show dependency treegraph
 
Reported: 2008-12-10 21:28 EST by Fred Wells
Modified: 2014-03-16 23:16 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-16 10:06:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
start of a patch (542 bytes, patch)
2008-12-11 10:36 EST, Bill Nottingham
no flags Details | Diff

  None (edit)
Description Fred Wells 2008-12-10 21:28:06 EST
Description of problem:

rc.sysinit drops into text mode (plymouth --hide-splash) when detecting non-luks encrypted filesystems, even if the filesystems are otherwise properly created with cryptsetup (sans luksFormat).

Version-Release number of selected component (if applicable):

Fedora 10
initscripts-8.86-1.i386

How reproducible:

Every time

Steps to Reproduce:
1.  Create non-luks encrypted filesystem using cryptsetup
2.  Update /etc/crypttab accordingly
3.  Reboot
  
Actual results:

Plymouth drops into text mode at line 233 of /etc/rc.d/rc.sysinit due to detection of non-luks formatted encrypted filesystem.

Expected results:

Since non-luks encryption is perfectly valid, Fedora shouldn't drop into text mode as though this is an error.

Additional info:

I'm really not looking forward to reformatting my encrypted filesystems.  Would be great if Fedora was less restrictive.
Comment 1 Fred Wells 2008-12-11 09:25:16 EST
This problem is also triggered simply by encrypting "swap", whether luks or not.   I guess I don't understand why either condition should force text boot.
Comment 2 Bill Nottingham 2008-12-11 10:36:12 EST
Created attachment 326630 [details]
start of a patch

Try this  - it should catch the first part where this triggers.
Comment 3 Fred Wells 2008-12-11 18:29:11 EST
That works!  

Tested with a a mix of luks and non-luks encrypted filesystems as well as swap.

Will this fix be making it's way into a future initscripts update?
Comment 4 Bill Nottingham 2008-12-16 10:06:53 EST
At some point, yes.

Fixed in  http://git.fedorahosted.org/git/?p=initscripts.git;a=commitdiff;h=7b8ad9cd0d276da648bb41ffa9fb27f2b123e07f (ignore the changelog, it's for the other part of that change.)

Note You need to log in before you can comment on or make changes to this bug.