Bug 475919 - Requires missing for preinstall script
Requires missing for preinstall script
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: nethack-vultures (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Karen Pease
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-10 23:31 EST by Bruno Wolff III
Modified: 2009-01-14 21:54 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-10 22:57:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruno Wolff III 2008-12-10 23:31:32 EST
Description of problem:
The preinstall script for nethack-vultures uses both rm (provided by coreutils) and groupadd (provided by shadow-utils). There should by Requires(pre) for both of these to make sure coreutils and shadowutils are installed before the prescript is run. Failure to do this can cause problems during fresh installs and livecd builds.
You should be able to add the following to the spec file:
Requires(pre): coreutils
Requires(pre): shadow-utils

Version-Release number of selected component (if applicable):
nethack-vultures-2.1.0-14.fc10.i386

How reproducible:
The error can be seen by examining the spec file. Whether or not the symptoms show up is somewhat random based on the install order.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

In useradd is only used in the preinstall script you shouldn't have to use the normal requires for it.
Comment 1 Karen Pease 2008-12-11 22:47:24 EST
I added the changes, but unfortunately, I don't seem to be able to commit changes anymore -- "Permission denied (publickey).  So, I'm not sure what to do.
Comment 2 Bruno Wolff III 2008-12-12 14:48:58 EST
You should be able to fix that in the Fedora Account System. I don't know exactly what you need to do though. You could probably get a good answer in most fedora forums or mailing lists.
Comment 3 Bruno Wolff III 2009-01-07 16:39:04 EST
The deadline for the alpha release is coming up quickly. Can you try to get some help with your problem related to your Fedora key soon?
Comment 4 Karen Pease 2009-01-07 17:57:14 EST
I couldn't find how to fix it in the Fedora Account System, Unfortunately, I'm very busy right now; fixing software bugs is one thing, but having to also deal with Fedora connection problems is another.  If someone can tell me a quick way to fix my account, I'd be glad to commit the changes, but I probably won't have time to deal with getting my account fixed for another couple months.
Comment 5 Bruno Wolff III 2009-01-07 20:06:29 EST
Thanks for the update on your status. I have already been asking for help for this, since it is something any maintainer can do. If no one steps in in the next day or two I'll make another request including your updated status.
Comment 6 Gwyn Ciesla 2009-01-08 12:16:06 EST
I'm a provenpackager, and would be willing to commit/build.  Just the two Requires(pre), correct?
Comment 7 Gwyn Ciesla 2009-01-08 13:02:20 EST
I have this ready to go, if this is all there is to do.

Karen, if you'd like assistance re-diffing the patches so that the default_fuzz workaround can be removed, let me know.
Comment 8 Karen Pease 2009-01-08 13:56:56 EST
Thanks for taking care of that.  When I get my account fixed, I'll look into that. 

Thanks again!
Comment 9 Gwyn Ciesla 2009-01-08 14:03:39 EST
Anytime.  Committing and building, and I'll do a bodhi update for F-10.
Comment 10 Fedora Update System 2009-01-08 14:38:45 EST
nethack-vultures-2.1.0-15.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/nethack-vultures-2.1.0-15.fc10
Comment 11 Bruno Wolff III 2009-01-08 15:55:20 EST
Yes, just the two Requires(pre) needed to be added. The package was getting install too early during livecd-creator builds and that will fix that problem.
Thanks for stepping in to help out here!
Comment 12 Bruno Wolff III 2009-01-10 22:57:44 EST
I am not seeing dependency errors any more in rawhide, so I am going to close this. Thanks.
Comment 13 Fedora Update System 2009-01-14 21:54:50 EST
nethack-vultures-2.1.0-15.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.