Bug 475921 - The post install and uninstall scripts require coreutils
The post install and uninstall scripts require coreutils
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: vodovod (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Karel Volný
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-10 23:54 EST by Bruno Wolff III
Modified: 2009-01-07 04:38 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-04 01:02:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruno Wolff III 2008-12-10 23:54:55 EST
Description of problem:
The spec file for vodovod doesn't require coreutils for the post install and post uninstall scripts. This can cause problems during fresh installs or when build live cds.
You can include the following in the spec file to fix this:
Requires(post): coreutils
Requires(postun): coreutils


Version-Release number of selected component (if applicable):
vodovod-1.10-2.fc9.i386

How reproducible:
The error can be verified by examining the spec file. The symptoms can show up randomly based on install order.


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Karel Volný 2008-12-11 11:37:49 EST
fixed in devel

should I also get it into F10, 9, 8 ...?
Comment 2 Bruno Wolff III 2008-12-11 11:47:31 EST
In theory back versions should get fixed, but actually I am mostly interested in going forward, since I volunteered to get a games spin working for F11. And the issue was causing errors during its build.
If it's easy for you to do, I would suggest fixing it everywhere as it's a pretty safe change.
Comment 3 Fedora Update System 2008-12-12 06:20:26 EST
vodovod-1.10-3.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/vodovod-1.10-3.fc8
Comment 4 Fedora Update System 2008-12-12 06:36:01 EST
vodovod-1.10-3.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/vodovod-1.10-3.fc9
Comment 5 Fedora Update System 2008-12-12 07:09:50 EST
vodovod-1.10-3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/vodovod-1.10-3.fc10
Comment 6 Karel Volný 2008-12-12 07:16:17 EST
so here are the updated packages, please test if you have the possibility

also, I'd be glad if you'd try playing the game from the devel branch, and report back - if it works flawlessly, I'd like to ask the author to release new version before F11 gets frozen (so that we use official tarball instead of svn sources)
Comment 7 Bruno Wolff III 2008-12-12 14:54:09 EST
I'll try out the game. My main interest is actually in how it gets installed when running livecd-creator since I have volunteered to get the games spin whipped back into shape so that there is one for f11.
I don't have rawhide installed right now, though I'll probably switch over my home machine to rawhide in a week or two.
Comment 8 Fedora Update System 2008-12-13 10:02:00 EST
vodovod-1.10-3.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update vodovod'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-11223
Comment 9 Fedora Update System 2008-12-13 10:02:39 EST
vodovod-1.10-3.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update vodovod'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2008-11226
Comment 10 Fedora Update System 2008-12-13 10:05:32 EST
vodovod-1.10-3.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update vodovod'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-11242
Comment 11 Bruno Wolff III 2008-12-13 14:52:47 EST
When running livecd-creator on F10 I no longer see an install error for vodovod.
I tried playing the game as well and it seemed to work OK.
Comment 12 Karel Volný 2008-12-15 03:57:21 EST
(In reply to comment #11)
> When running livecd-creator on F10 I no longer see an install error for
> vodovod.
> I tried playing the game as well and it seemed to work OK.

thankyou for trying that (and for the efforts to prepare the game spin too!)

if you happen to have some spare time after upgrading to rawhide, I'd be glad to hear back again
Comment 13 Bruno Wolff III 2009-01-04 01:02:02 EST
I am not seeing the install issue on either F10 nor rawhide so I am going to close this.
Comment 14 Fedora Update System 2009-01-07 04:33:35 EST
vodovod-1.10-3.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2009-01-07 04:37:40 EST
vodovod-1.10-3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2009-01-07 04:38:00 EST
vodovod-1.10-3.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.