Bug 475938 - [ALL LANG] Application is not running any languages/locale
[ALL LANG] Application is not running any languages/locale
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: file-roller (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Christopher Aillon
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-11 01:46 EST by A S Alam
Modified: 2013-07-02 20:50 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-23 04:00:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description A S Alam 2008-12-11 01:46:03 EST
Description of problem:
While using file-roller in Punjabi (pa_IN.UTF-8), it was not 
showing translation, while package has Translated file

Version-Release number of selected component (if applicable):
file-roller-2.24.2-1.fc10.i386

How reproducible:
Everytime

Steps to Reproduce:
1. open termianl
2. export LANG=ja_JP.UTF-8 
3.file-roller
  
Actual results:
No Translated message in application

Expected results:
Should have, when rpm has Translated MO files


Additional info:
Tested lang: kn_IN, ja_JP, zh_TW,
---
rpm -ql file-roller
---
/usr/share/locale/af/LC_MESSAGES/file-roller.mo            
/usr/share/locale/am/LC_MESSAGES/file-roller.mo            
/usr/share/locale/ar/LC_MESSAGES/file-roller.mo            
/usr/share/locale/as/LC_MESSAGES/file-roller.mo            
/usr/share/locale/az/LC_MESSAGES/file-roller.mo            
/usr/share/locale/be/LC_MESSAGES/file-roller.mo            
/usr/share/locale/be@latin/LC_MESSAGES/file-roller.mo      
/usr/share/locale/bg/LC_MESSAGES/file-roller.mo            
/usr/share/locale/bn/LC_MESSAGES/file-roller.mo            
/usr/share/locale/bn_IN/LC_MESSAGES/file-roller.mo         
/usr/share/locale/br/LC_MESSAGES/file-roller.mo            
/usr/share/locale/bs/LC_MESSAGES/file-roller.mo            
/usr/share/locale/ca/LC_MESSAGES/file-roller.mo            
/usr/share/locale/cs/LC_MESSAGES/file-roller.mo            
/usr/share/locale/cy/LC_MESSAGES/file-roller.mo            
/usr/share/locale/da/LC_MESSAGES/file-roller.mo            
/usr/share/locale/de/LC_MESSAGES/file-roller.mo            
/usr/share/locale/dz/LC_MESSAGES/file-roller.mo            
/usr/share/locale/el/LC_MESSAGES/file-roller.mo            
/usr/share/locale/en_CA/LC_MESSAGES/file-roller.mo         
/usr/share/locale/en_GB/LC_MESSAGES/file-roller.mo         
/usr/share/locale/es/LC_MESSAGES/file-roller.mo            
/usr/share/locale/et/LC_MESSAGES/file-roller.mo            
/usr/share/locale/eu/LC_MESSAGES/file-roller.mo            
/usr/share/locale/fa/LC_MESSAGES/file-roller.mo            
/usr/share/locale/fi/LC_MESSAGES/file-roller.mo            
/usr/share/locale/fr/LC_MESSAGES/file-roller.mo            
/usr/share/locale/fur/LC_MESSAGES/file-roller.mo           
/usr/share/locale/ga/LC_MESSAGES/file-roller.mo            
/usr/share/locale/gl/LC_MESSAGES/file-roller.mo            
/usr/share/locale/gu/LC_MESSAGES/file-roller.mo            
/usr/share/locale/he/LC_MESSAGES/file-roller.mo            
/usr/share/locale/hi/LC_MESSAGES/file-roller.mo            
/usr/share/locale/hr/LC_MESSAGES/file-roller.mo            
/usr/share/locale/hu/LC_MESSAGES/file-roller.mo            
/usr/share/locale/hy/LC_MESSAGES/file-roller.mo            
/usr/share/locale/id/LC_MESSAGES/file-roller.mo            
/usr/share/locale/is/LC_MESSAGES/file-roller.mo            
/usr/share/locale/it/LC_MESSAGES/file-roller.mo            
/usr/share/locale/ja/LC_MESSAGES/file-roller.mo            
/usr/share/locale/ka/LC_MESSAGES/file-roller.mo            
/usr/share/locale/kn/LC_MESSAGES/file-roller.mo            
/usr/share/locale/ko/LC_MESSAGES/file-roller.mo            
/usr/share/locale/ku/LC_MESSAGES/file-roller.mo            
/usr/share/locale/lt/LC_MESSAGES/file-roller.mo            
/usr/share/locale/lv/LC_MESSAGES/file-roller.mo            
/usr/share/locale/mg/LC_MESSAGES/file-roller.mo            
/usr/share/locale/mk/LC_MESSAGES/file-roller.mo            
/usr/share/locale/ml/LC_MESSAGES/file-roller.mo            
/usr/share/locale/mn/LC_MESSAGES/file-roller.mo            
/usr/share/locale/mr/LC_MESSAGES/file-roller.mo            
/usr/share/locale/ms/LC_MESSAGES/file-roller.mo            
/usr/share/locale/nb/LC_MESSAGES/file-roller.mo            
/usr/share/locale/ne/LC_MESSAGES/file-roller.mo            
/usr/share/locale/nl/LC_MESSAGES/file-roller.mo            
/usr/share/locale/nn/LC_MESSAGES/file-roller.mo            
/usr/share/locale/oc/LC_MESSAGES/file-roller.mo            
/usr/share/locale/or/LC_MESSAGES/file-roller.mo            
/usr/share/locale/pa/LC_MESSAGES/file-roller.mo            
/usr/share/locale/pl/LC_MESSAGES/file-roller.mo            
/usr/share/locale/ps/LC_MESSAGES/file-roller.mo            
/usr/share/locale/pt/LC_MESSAGES/file-roller.mo            
/usr/share/locale/pt_BR/LC_MESSAGES/file-roller.mo         
/usr/share/locale/ro/LC_MESSAGES/file-roller.mo            
/usr/share/locale/ru/LC_MESSAGES/file-roller.mo            
/usr/share/locale/rw/LC_MESSAGES/file-roller.mo            
/usr/share/locale/si/LC_MESSAGES/file-roller.mo            
/usr/share/locale/sk/LC_MESSAGES/file-roller.mo            
/usr/share/locale/sl/LC_MESSAGES/file-roller.mo            
/usr/share/locale/sq/LC_MESSAGES/file-roller.mo            
/usr/share/locale/sr/LC_MESSAGES/file-roller.mo            
/usr/share/locale/sr@ije/LC_MESSAGES/file-roller.mo        
/usr/share/locale/sr@latin/LC_MESSAGES/file-roller.mo      
/usr/share/locale/sv/LC_MESSAGES/file-roller.mo            
/usr/share/locale/ta/LC_MESSAGES/file-roller.mo
/usr/share/locale/te/LC_MESSAGES/file-roller.mo
/usr/share/locale/th/LC_MESSAGES/file-roller.mo
/usr/share/locale/tk/LC_MESSAGES/file-roller.mo
/usr/share/locale/tr/LC_MESSAGES/file-roller.mo
/usr/share/locale/uk/LC_MESSAGES/file-roller.mo
/usr/share/locale/ur/LC_MESSAGES/file-roller.mo
/usr/share/locale/ur_PK/LC_MESSAGES/file-roller.mo
/usr/share/locale/vi/LC_MESSAGES/file-roller.mo
/usr/share/locale/xh/LC_MESSAGES/file-roller.mo
/usr/share/locale/zh_CN/LC_MESSAGES/file-roller.mo
/usr/share/locale/zh_HK/LC_MESSAGES/file-roller.mo
/usr/share/locale/zh_TW/LC_MESSAGES/file-roller.mo
-----
Comment 1 A S Alam 2009-01-21 02:37:40 EST
ping pls
Comment 2 A S Alam 2009-01-21 02:51:54 EST
working fine with rawhide (file-roller-2.25.1-5.fc11)
Comment 3 norbert 2009-05-20 05:27:38 EDT
might be a bug of its own, but maybe fits into the context:

could it be general problems with locales and/or glibc in fc11.i386 !?

ever since since the last glibc-update (glibc-2.10.1-1.i686) i keep running into problems like  

 # locale -a
 locale: Cannot set LC_CTYPE to default locale: No such file or directory
 locale: Cannot set LC_MESSAGES to default locale: No such file or directory
 locale: Cannot set LC_COLLATE to default locale: No such file or directory
 C
 POSIX

localedef, too, does not quite what it (supposedly) should...
 
 # localedef -i en_US -c -f UTF-8 en_US.UTF-8
 **Floating point exception**
 #
Comment 4 Parag Nemade 2009-06-23 04:00:46 EDT
tested and this looks fixed in file-roller-2.24.3-1.fc10

Note You need to log in before you can comment on or make changes to this bug.