Bug 475945 - mouse buttons (and sometimes keyboard) stop to work
mouse buttons (and sometimes keyboard) stop to work
Status: CLOSED DUPLICATE of bug 473825
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-evdev (Show other bugs)
10
All Linux
high Severity medium
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-11 03:01 EST by josef radinger
Modified: 2008-12-17 18:34 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-17 18:34:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (2.78 KB, text/plain)
2008-12-11 03:05 EST, josef radinger
no flags Details

  None (edit)
Description josef radinger 2008-12-11 03:01:42 EST
Description of problem:
updated to fedora10. i have a xinerama config with nvidia cards (with the closed source driver from nvidia/rpmfusion). used to work with fedora8. after some work it worked with fedora10 and xserver1.5, too. but every 5-10 minutes i lose my mousebuttons (the mouse-pointer is visible and seems to work, but i cannot click). keyboard used to work, but today even my keyboard stopped to work.

Setup: 2 nvidias, 2 monitors, 1 keyboard, but 2 mice

Xorg.0.log has:

(II) config/hal: Adding input device AT Translated Set 2 keyboard
(EE) config/hal: NewInputDeviceRequest failed
(II) config/hal: Adding input device Power Button (CM)
(EE) config/hal: NewInputDeviceRequest failed
(II) config/hal: Adding input device Power Button (FF)
(EE) config/hal: NewInputDeviceRequest failed
(II) config/hal: Adding input device ImExPS/2 Logitech Explorer Mouse
(EE) config/hal: NewInputDeviceRequest failed
(II) config/hal: Adding input device Macintosh mouse button emulation
(EE) config/hal: NewInputDeviceRequest failed


How reproducible:
restart X and wait
Comment 1 josef radinger 2008-12-11 03:05:38 EST
Created attachment 326593 [details]
xorg.conf
Comment 2 Peter Hutterer 2008-12-11 21:10:09 EST
Maybe a dupe of 473825?
Comment 3 josef radinger 2008-12-12 02:06:03 EST
im not sure if this is the same problem, but i will try to use the mentioned debugging-software and come back with infos as soon as i have them.
Comment 4 josef radinger 2008-12-12 04:26:54 EST
xev shows no reaction for mouse-clicks, as this is happening. i can though move the mouse and currently i can start programs via keyboard.
Comment 5 josef radinger 2008-12-12 04:43:45 EST
/proc/bus/input/devides:

i removed all non-mouse devices

I: Bus=0017 Vendor=0001 Product=0001 Version=0100
N: Name="Macintosh mouse button emulation"
P: Phys=
S: Sysfs=/devices/virtual/input/input2
U: Uniq=
H: Handlers=mouse0 event2 
B: EV=7
B: KEY=70000 0 0 0 0 0 0 0 0
B: REL=3

I: Bus=0011 Vendor=0002 Product=0006 Version=003e
N: Name="ImExPS/2 Logitech Explorer Mouse"
P: Phys=isa0060/serio1/input0
S: Sysfs=/devices/platform/i8042/serio1/input/input5
U: Uniq=
H: Handlers=mouse2 event5 
B: EV=7
B: KEY=1f0000 0 0 0 0 0 0 0 0
B: REL=143

I: Bus=0003 Vendor=045e Product=0084 Version=0110
N: Name="Microsoft Basic Optical Mouse"
P: Phys=usb-0000:00:1d.2-2/input0
S: Sysfs=/devices/pci0000:00/0000:00:1d.2/usb4/4-2/4-2:1.0/input/input8
U: Uniq=
H: Handlers=mouse1 event4 
B: EV=17
B: KEY=70000 0 0 0 0 0 0 0 0
B: REL=103
B: MSC=10

event2: dead
event5: mouse clicks get through
[cheese@cheese xorg]$ ./evtest /dev/input/event5
Input driver version is 1.0.0
Input device ID: bus 0x11 vendor 0x2 product 0x6 version 0x3e
Input device name: "ImExPS/2 Logitech Explorer Mouse"
Supported events:
  Event type 0 (Sync)
  Event type 1 (Key)
    Event code 272 (LeftBtn)
    Event code 273 (RightBtn)
    Event code 274 (MiddleBtn)
    Event code 275 (SideBtn)
    Event code 276 (ExtraBtn)
  Event type 2 (Relative)
    Event code 0 (X)
    Event code 1 (Y)
    Event code 6 (HWheel)
    Event code 8 (Wheel)
Grab succeeded, ungrabbing.
Testing ... (interrupt to exit)
Event: time 1229074820.041428, type 1 (Key), code 272 (LeftBtn), value 1
Event: time 1229074820.041441, -------------- Report Sync ------------
Event: time 1229074820.164482, type 1 (Key), code 272 (LeftBtn), value 0
Event: time 1229074820.164495, -------------- Report Sync ------------
Event: time 1229074820.273045, type 1 (Key), code 272 (LeftBtn), value 1
Event: time 1229074820.273058, -------------- Report Sync ------------
Event: time 1229074820.387831, type 1 (Key), code 272 (LeftBtn), value 0
Event: time 1229074820.387844, -------------- Report Sync ------------
Event: time 1229074820.716694, type 1 (Key), code 273 (RightBtn), value 1
Event: time 1229074820.716707, -------------- Report Sync ------------
Event: time 1229074820.798930, type 1 (Key), code 273 (RightBtn), value 0
Event: time 1229074820.798943, -------------- Report Sync ------------
Event: time 1229074820.886977, type 1 (Key), code 273 (RightBtn), value 1
Event: time 1229074820.886990, -------------- Report Sync ------------
Event: time 1229074820.985201, type 1 (Key), code 273 (RightBtn), value 0
Event: time 1229074820.985213, -------------- Report Sync ------------

event4: mouse clicks get through
[cheese@cheese xorg]$ ./evtest /dev/input/event4
Input driver version is 1.0.0
Input device ID: bus 0x3 vendor 0x45e product 0x84 version 0x110
Input device name: "Microsoft Basic Optical Mouse"
Supported events:
  Event type 0 (Sync)
  Event type 1 (Key)
    Event code 272 (LeftBtn)
    Event code 273 (RightBtn)
    Event code 274 (MiddleBtn)
  Event type 2 (Relative)
    Event code 0 (X)
    Event code 1 (Y)
    Event code 8 (Wheel)
  Event type 4 (Misc)
    Event code 4 (ScanCode)
Grab succeeded, ungrabbing.
Testing ... (interrupt to exit)
Event: time 1229074903.229289, type 4 (Misc), code 4 (ScanCode), value 90001
Event: time 1229074903.229295, type 1 (Key), code 272 (LeftBtn), value 1
Event: time 1229074903.229307, -------------- Report Sync ------------
Event: time 1229074903.405266, type 4 (Misc), code 4 (ScanCode), value 90001
Event: time 1229074903.405271, type 1 (Key), code 272 (LeftBtn), value 0
Event: time 1229074903.405283, -------------- Report Sync ------------
Event: time 1229074903.597246, type 4 (Misc), code 4 (ScanCode), value 90002
Event: time 1229074903.597251, type 1 (Key), code 273 (RightBtn), value 1
Event: time 1229074903.597262, -------------- Report Sync ------------
Event: time 1229074903.613243, type 2 (Relative), code 0 (X), value -1
Event: time 1229074903.613246, type 2 (Relative), code 1 (Y), value 1
Event: time 1229074903.613255, -------------- Report Sync ------------
Event: time 1229074903.773220, type 4 (Misc), code 4 (ScanCode), value 90002
Event: time 1229074903.773225, type 1 (Key), code 273 (RightBtn), value 0
Event: time 1229074903.773236, -------------- Report Sync ------------
Event: time 1229074903.797220, type 2 (Relative), code 0 (X), value -1
Event: time 1229074903.797232, -------------- Report Sync ------------

event2: no reaction if i click one of my 2 mice
[cheese@cheese xorg]$ ./evtest /dev/input/event2
Input driver version is 1.0.0
Input device ID: bus 0x17 vendor 0x1 product 0x1 version 0x100
Input device name: "Macintosh mouse button emulation"
Supported events:
  Event type 0 (Sync)
  Event type 1 (Key)
    Event code 272 (LeftBtn)
    Event code 273 (RightBtn)
    Event code 274 (MiddleBtn)
  Event type 2 (Relative)
    Event code 0 (X)
    Event code 1 (Y)
Grab succeeded, ungrabbing.
Testing ... (interrupt to exit)

i was not aware i had a macintosh-thingy, but im not too sure what this should be.
Comment 6 Peter Hutterer 2008-12-14 17:52:50 EST
that's an in-kernel emulation for one-button mice. don't worry about it if you don't have a use for it.


try xdpyinfo | grep root to get the root window ID, then run xev -id <root window id> when the mouse doesn't work.
Comment 7 josef radinger 2008-12-17 07:44:17 EST
interesting:
my system kept stable until today in the morning. 

xev -id 0x125 > /tmp/xev.txt 2>&1 shows that i receive buttonpresses and releases and of cource motions.

ButtonPress event, serial 13, synthetic NO, window 0x127,
    root 0x127, subw 0x0, time 99630271, (1891,649), root:(1891,649),
    state 0x10, button 1, same_screen YES

ButtonRelease event, serial 13, synthetic NO, window 0x127,
    root 0x127, subw 0x0, time 99630448, (1891,649), root:(1891,649),
    state 0x110, button 1, same_screen YES

ButtonPress event, serial 13, synthetic NO, window 0x127,
    root 0x127, subw 0x0, time 99630852, (1891,649), root:(1891,649),
    state 0x10, button 1, same_screen YES

ButtonRelease event, serial 13, synthetic NO, window 0x127,
    root 0x127, subw 0x0, time 99631028, (1891,649), root:(1891,649),
    state 0x110, button 1, same_screen YES

ButtonPress event, serial 13, synthetic NO, window 0x127,
    root 0x127, subw 0x0, time 99632222, (1891,649), root:(1891,649),
    state 0x10, button 2, same_screen YES

ButtonRelease event, serial 13, synthetic NO, window 0x127,
    root 0x127, subw 0x0, time 99632460, (1891,649), root:(1891,649),
    state 0x210, button 2, same_screen YES

MotionNotify event, serial 13, synthetic NO, window 0x127,
    root 0x127, subw 0x0, time 99632871, (1883,659), root:(1883,659),
    state 0x10, is_hint 0, same_screen YES

MotionNotify event, serial 13, synthetic NO, window 0x127,
    root 0x127, subw 0x0, time 99632891, (1875,677), root:(1875,677),
Comment 8 Peter Hutterer 2008-12-17 18:34:07 EST
Closing this as duplicate of Bug 473825. If the mouse doesn't work but the root window still sees the event this is exactly the same problem.

*** This bug has been marked as a duplicate of bug 473825 ***

Note You need to log in before you can comment on or make changes to this bug.