Bug 475953 - virt-manager crashes the second time I try to open vnc window on a running virtual machine
virt-manager crashes the second time I try to open vnc window on a running vi...
Status: CLOSED DUPLICATE of bug 471072
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-11 04:54 EST by Luca Foppiano
Modified: 2008-12-11 05:38 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-11 05:38:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luca Foppiano 2008-12-11 04:54:24 EST
Description of problem:
virt-manager crashes the second time I try to open vnc window on a virtual machine

Version-Release number of selected component (if applicable):
virt-manager-0.6.0-4.fc10.x86_64

How reproducible:
always

Steps to Reproduce:
1. Start a virt-manager
2. Start a virtual machine
3. Double click (or left click and "open") on that virtual machine and virt-manager open the vnc window
4. Close that window
5. Double click (or left click and "open") again on virtual machine
6. Virt manager crashes
  

Additional info:

Here the stacktrace of virt-manager launched with --no-fork

*** glibc detected *** python: munmap_chunk(): invalid pointer: 0x0000003dee2b8b60 ***
======= Backtrace: =========
/lib64/libc.so.6[0x3dd5477e98]
/usr/lib64/gtk-2.0/modules/libgnomebreakpad.so[0x7f2d72a1f581]
/usr/lib64/gtk-2.0/modules/libgnomebreakpad.so[0x7f2d72a1f769]
/lib64/libpthread.so.0[0x3dd600f0f0]
/usr/lib64/libgtk-vnc-1.0.so.0[0x7f2d6f6a7a5c]
/usr/lib64/libgtk-vnc-1.0.so.0[0x7f2d6f6a855b]
/usr/lib64/libgtk-x11-2.0.so.0[0x3b0c729528]
/lib64/libgobject-2.0.so.0(g_closure_invoke+0x16d)[0x3b09e0b7dd]
/lib64/libgobject-2.0.so.0[0x3b09e2119b]
/lib64/libgobject-2.0.so.0(g_signal_emit_valist+0x63a)[0x3b09e229ea]
/lib64/libgobject-2.0.so.0(g_signal_emit+0x83)[0x3b09e23093]
/usr/lib64/libgtk-x11-2.0.so.0[0x3b0c82c26e]
/usr/lib64/libgtk-x11-2.0.so.0[0x3b0c6b2994]
/lib64/libgobject-2.0.so.0(g_closure_invoke+0xbf)[0x3b09e0b72f]
/lib64/libgobject-2.0.so.0[0x3b09e20dd8]
/lib64/libgobject-2.0.so.0(g_signal_emit_valist+0x7b8)[0x3b09e22b68]
/lib64/libgobject-2.0.so.0(g_signal_emit+0x83)[0x3b09e23093]
/usr/lib64/libgtk-x11-2.0.so.0(gtk_widget_size_allocate+0x14a)[0x3b0c832aea]
/usr/lib64/libgtk-x11-2.0.so.0[0x3b0c829e48]
/lib64/libgobject-2.0.so.0(g_closure_invoke+0xbf)[0x3b09e0b72f]
/lib64/libgobject-2.0.so.0[0x3b09e20dd8]
/lib64/libgobject-2.0.so.0(g_signal_emit_valist+0x7b8)[0x3b09e22b68]
/lib64/libgobject-2.0.so.0(g_signal_emit+0x83)[0x3b09e23093]
/usr/lib64/libgtk-x11-2.0.so.0(gtk_widget_size_allocate+0x14a)[0x3b0c832aea]
/usr/lib64/libgtk-x11-2.0.so.0[0x3b0c77f88d]
/lib64/libgobject-2.0.so.0(g_closure_invoke+0xbf)[0x3b09e0b72f]
/lib64/libgobject-2.0.so.0[0x3b09e20dd8]
/lib64/libgobject-2.0.so.0(g_signal_emit_valist+0x7b8)[0x3b09e22b68]
/lib64/libgobject-2.0.so.0(g_signal_emit+0x83)[0x3b09e23093]
/usr/lib64/libgtk-x11-2.0.so.0(gtk_widget_size_allocate+0x14a)[0x3b0c832aea]
/usr/lib64/libgtk-x11-2.0.so.0[0x3b0c748c18]
/lib64/libgobject-2.0.so.0(g_closure_invoke+0xbf)[0x3b09e0b72f]
/lib64/libgobject-2.0.so.0[0x3b09e20dd8]
/lib64/libgobject-2.0.so.0(g_signal_emit_valist+0x7b8)[0x3b09e22b68]
/lib64/libgobject-2.0.so.0(g_signal_emit+0x83)[0x3b09e23093]
/usr/lib64/libgtk-x11-2.0.so.0(gtk_widget_size_allocate+0x14a)[0x3b0c832aea]
/usr/lib64/libgtk-x11-2.0.so.0[0x3b0c748c18]
/lib64/libgobject-2.0.so.0(g_closure_invoke+0xbf)[0x3b09e0b72f]
/lib64/libgobject-2.0.so.0[0x3b09e20dd8]
/lib64/libgobject-2.0.so.0(g_signal_emit_valist+0x7b8)[0x3b09e22b68]
/lib64/libgobject-2.0.so.0(g_signal_emit+0x83)[0x3b09e23093]
/usr/lib64/libgtk-x11-2.0.so.0(gtk_widget_size_allocate+0x14a)[0x3b0c832aea]
/usr/lib64/libgtk-x11-2.0.so.0[0x3b0c828650]
/lib64/libgobject-2.0.so.0(g_closure_invoke+0xbf)[0x3b09e0b72f]
/lib64/libgobject-2.0.so.0[0x3b09e20dd8]
/lib64/libgobject-2.0.so.0(g_signal_emit_valist+0x7b8)[0x3b09e22b68]
/lib64/libgobject-2.0.so.0(g_signal_emit+0x83)[0x3b09e23093]
/usr/lib64/libgtk-x11-2.0.so.0(gtk_widget_size_allocate+0x14a)[0x3b0c832aea]
/usr/lib64/libgtk-x11-2.0.so.0[0x3b0c8432d6]
/lib64/libgobject-2.0.so.0(g_closure_invoke+0x16d)[0x3b09e0b7dd]
/lib64/libgobject-2.0.so.0[0x3b09e20dd8]
/lib64/libgobject-2.0.so.0(g_signal_emit_valist+0x7b8)[0x3b09e22b68]
/lib64/libgobject-2.0.so.0(g_signal_emit+0x83)[0x3b09e23093]
/usr/lib64/libgtk-x11-2.0.so.0(gtk_widget_size_allocate+0x14a)[0x3b0c832aea]
/usr/lib64/libgtk-x11-2.0.so.0[0x3b0c84379c]
/lib64/libgobject-2.0.so.0(g_closure_invoke+0x16d)[0x3b09e0b7dd]
/lib64/libgobject-2.0.so.0[0x3b09e2119b]
/lib64/libgobject-2.0.so.0(g_signal_emit_valist+0x7b8)[0x3b09e22b68]
/lib64/libgobject-2.0.so.0(g_signal_emit+0x83)[0x3b09e23093]
/usr/lib64/libgtk-x11-2.0.so.0[0x3b0c6ab110]
/usr/lib64/libgdk-x11-2.0.so.0[0x3b0be1b59b]
/lib64/libglib-2.0.so.0(g_main_context_dispatch+0x23b)[0x3b09a3779b]
/lib64/libglib-2.0.so.0[0x3b09a3af6d]
======= Memory map: ========
00110000-00120000 r-xp 00000000 fd:00 2357165                            /usr/lib64/python2.5/site-packages/libvirtmod.so
00120000-00320000 ---p 00010000 fd:00 2357165                            /usr/lib64/python2.5/site-packages/libvirtmod.so
00320000-00322000 rw-p 00010000 fd:00 2357165 Multiple segmentation faults occurred; can't display error dialog
Comment 1 Daniel Berrange 2008-12-11 05:38:57 EST

*** This bug has been marked as a duplicate of bug 471072 ***

Note You need to log in before you can comment on or make changes to this bug.