Bug 47596 - /sbin/service named start doesn't recognize running copy
Summary: /sbin/service named start doesn't recognize running copy
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: bind   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-06 07:45 UTC by John William
Modified: 2007-04-18 16:34 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-06 07:45:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John William 2001-07-06 07:45:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)

Description of problem:
Running '/sbin/service named start' spawns additional copies of named 
every time the command is run. The new copies recognize (and log 
to /var/messages) that the port is in use, but do not exit - this can fill 
up the machine with processes (and threads on SMP) quickly.

How reproducible:
Always

Steps to Reproduce:
1. run '/sbin/service named start'
2.
3.
	

Actual Results:  Spawns additional copies of named each time the command 
is run (one thread per CPU and per port on which named is listening).

Expected Results:  Should recognize that named is already running and not 
spawn additional programs.

Additional info:

[root@copper RPMS]# rpm -q bind caching-nameserver
bind-9.1.0-10
caching-nameserver-7.1-3

Standard 7.1 system. I marked the bug as normal priority even though it's 
pretty easy to bring down a machine with linuxconf (because it keeps 
starting named).

Comment 1 Bernhard Rosenkraenzer 2001-07-19 10:18:29 UTC
Fixed in 9.1.3-3


Comment 2 Karl schmidt 2001-07-30 17:39:34 UTC
I have seen this problem also


Note You need to log in before you can comment on or make changes to this bug.