Bug 475992 - dia crashes on start: Couldn't find standard objects
dia crashes on start: Couldn't find standard objects
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dia (Show other bugs)
rawhide
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Huzaifa S. Sidhpurwala
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-11 08:47 EST by Horst H. von Brand
Modified: 2009-01-05 08:44 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-03 23:19:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dia-0.96.1-so-plugin.patch (417 bytes, patch)
2009-01-03 14:02 EST, Horst H. von Brand
no flags Details | Diff
dia.spec for 0.9.6.1-9.1 (12.07 KB, application/octet-stream)
2009-01-03 14:03 EST, Horst H. von Brand
no flags Details

  None (edit)
Description Horst H. von Brand 2008-12-11 08:47:10 EST
Description of problem:
Starting dia crashes immediately.

Version-Release number of selected component (if applicable):
dia-0.96.1-9.fc11.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Start dia in a gnome-terminal
2.
3.
  
Actual results:
Gtk-Message: Failed to load module "pk-gtk-module": libpk-gtk-module.so: cannot open shared object file: No such file or directory

** (dia:8932): CRITICAL **: Couldn't find standard objects when looking for object-libs in '/usr/lib64/dia'; exiting...

Expected results:
Start dia

Additional info:
This maybe isn't dia's fault, it used to work recently (after its last update, IIRC)
Comment 1 Horst H. von Brand 2008-12-11 14:08:17 EST
The spam "Gtk message..." is due to missing PackageKit-gtk-module (reported as 476066)
Comment 2 Huzaifa S. Sidhpurwala 2008-12-11 22:39:05 EST
I agree, closing the bug
Comment 3 Horst H. von Brand 2008-12-12 12:23:55 EST
Nope, just the Gtk message part is fixed. dia still crashes, even after installing PackageKit-gtk-module.
Comment 4 Jonathan Corbet 2008-12-15 15:37:29 EST
I have this problem too, with dia-0.96.1-9.fc11.x86_64 and PackageKit-gtk-module-0.4.0-1.fc11.x86_64.

The weird thing is that, according to strace, it's not actually looking for a whole lot of stuff in that directory - just a few standard libraries which it subsequently finds in their proper homes.
Comment 5 Ola Thoresen 2008-12-27 08:34:34 EST
Same on my i386 here:

$ dia

** (dia:4481): CRITICAL **: Couldn't find standard objects when looking for object-libs in '/usr/lib/dia'; exiting...

$ rpm -q dia
dia-0.96.1-9.fc11.i386
Comment 6 Huzaifa S. Sidhpurwala 2009-01-02 22:35:46 EST
Ok,
Sorry for the delay here ,will work on this as soon as i am back from my vacation ie in 2-3 days.
Comment 7 Huzaifa S. Sidhpurwala 2009-01-02 22:48:05 EST
So here is what the problem is:
In the version 0.96.1-9
.la files were removed, this is what is causing this error, odd though.
Comment 8 Huzaifa S. Sidhpurwala 2009-01-03 06:16:36 EST
Simple Experiment:
Install the older version of dia ie dia-0.96.1-7.fc10.i386 this works fine.
Now remove the .la files from /usr/lib/dia and it crashes with exactly the same error.

This is exactly what has been done in 0.96-1-9.
After examining the source it seems that the function dia_register_plugins is looking at the .la files to determine where the dia libs are and when they dont exists its konks off.

I am going to talk to upstream to see if something can be done on this.

ccing Caolan McNamara on this bug as he made the last change to remove the .la files.

Caolan, 
any idea if dia was tested after making this change, as to if it worked?
Comment 9 Matthias Clasen 2009-01-03 10:13:46 EST
Looks like all you have to do is replace 

/* this one should work on any platform where libtool is used to compile dia */
#  define PLUG_IN_EXT ".la"
#  define PLUG_IN_EXT_LEN 3
#  define USING_LIBTOOL 1

by

#define PLUG_IN_EXT ".so"
#define PLUG_IN_EXT_LEN 3
#define USING_LIBTOOL 0
Comment 10 Horst H. von Brand 2009-01-03 14:00:46 EST
Yep, that fixes it. Resulting patch and spec file attached.

Thanks!
Comment 11 Horst H. von Brand 2009-01-03 14:02:09 EST
Created attachment 328113 [details]
dia-0.96.1-so-plugin.patch
Comment 12 Horst H. von Brand 2009-01-03 14:03:30 EST
Created attachment 328114 [details]
dia.spec for 0.9.6.1-9.1

A spec file using the patch, tested to fix the issue.
Comment 13 Huzaifa S. Sidhpurwala 2009-01-03 22:28:48 EST
I already have the patch committed, building the rpm now
Comment 14 Huzaifa S. Sidhpurwala 2009-01-03 23:14:49 EST
http://koji.fedoraproject.org/koji/buildinfo?buildID=77053 is now build and ready for testing
Comment 15 Caolan McNamara 2009-01-05 08:44:56 EST
Re #8 Hmm, I clearly didn't even run it once, sorry about that.

Note You need to log in before you can comment on or make changes to this bug.