Bug 475995 - randint give a wrong anware compared ro random_integers in numpy.
randint give a wrong anware compared ro random_integers in numpy.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: numpy (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-11 09:10 EST by Knut J BJuland
Modified: 2008-12-11 09:51 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-11 09:51:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A python file which show a bug in numpy.random.randint. (388 bytes, text/x-python)
2008-12-11 09:10 EST, Knut J BJuland
no flags Details

  None (edit)
Description Knut J BJuland 2008-12-11 09:10:46 EST
Created attachment 326619 [details]
A python file which show a bug in numpy.random.randint.

Description of problem:
When I use numpy.random.randint to simulat a game with dice it give the wrong ansaw compared to numpy.random.random_integers. I get a differetnt ansawer with randint. 

Version-Release number of selected component (if applicable):
1.2.0-1.fc10

How reproducible:
Everytime

Steps to Reproduce:
1. run the attament to se.
2.  
3.
  
Actual results:
randint and random_integer should give the same ansawer.

Expected results:


Additional info:
Comment 1 Knut J BJuland 2008-12-11 09:50:57 EST
It was not a bug. Since randint and random_intefers use different upper limits.

Note You need to log in before you can comment on or make changes to this bug.