Bug 476001 - [RHEL5.2] kdump to iSCSI device fails
[RHEL5.2] kdump to iSCSI device fails
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kexec-tools (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Neil Horman
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-11 09:49 EST by Flavio Leitner
Modified: 2009-02-17 13:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-04 15:13:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
suggested patch to add iSCSI support (7.07 KB, patch)
2008-12-11 09:50 EST, Flavio Leitner
no flags Details | Diff
console log with original mkdumprd failing with iSCSI devices (14.79 KB, text/plain)
2008-12-11 09:54 EST, Flavio Leitner
no flags Details

  None (edit)
Description Flavio Leitner 2008-12-11 09:49:04 EST
kdump to iSCSI device fails because the driver for iSCSI does not exist
in initrd.img. The initscripts in the initrd.img generated for kdump
also lacks the functions to
+ load the device driver for iSCSI
+ starting up the network, and
+ connecting to the iSCSI device.

Version-Release number of selected component (if applicable):
RHEL5.2 GA
 kexec-tools-1.102pre-21.el5

How reproducible:
Always

Steps to Reproduce:
1. Install RHEL5.2 GA and reboot.
2. Add the setting, which dump is saved to iSCSI device, to "/etc/kdump.conf".
3. Add "crashkernel=128M@16M" to kernel parameter.
4. Enable the kdump service by the following command.
  # chkconfig kdump on
5. Reboot the system.
  Note: Make kdump service effective manually after the system boots up when booted from iSCSI device.
6. Make a panic by the following command.
  # echo c > /proc/sysrq-trigger

Actual results:
kdump to iSCSI device fails.
See attached serial console log(rhel52x86-kdump-console.log) for detals.

Expected results:
kdump to iSCSI device succeeds.

Hardware info:
Server : Express5800/120Bb-6
OS     : RHEL5.2 GA
Kernel : 2.6.18-92.el5PAE
NIC    : Intel 82571EB Gigabit Ethernet Controller
iSCSI  : iStorage E1-10
HDD    : SATA 750GB x 4

The above-mentioned server is booted from the attached iSCSI device.
See attached sosreport for details.

Additional info:
- /etc/mkinitrd includes proper support for iSCSI devices. /sbin/mkdumprd should
 also be changed accordingly.

- Provided a patch based on mkinitrd to include iSCSI support in /sbin/mkdumprd
Comment 1 Flavio Leitner 2008-12-11 09:50:52 EST
Created attachment 326623 [details]
suggested patch to add iSCSI support
Comment 3 Flavio Leitner 2008-12-11 09:54:42 EST
Created attachment 326625 [details]
console log with original mkdumprd failing with iSCSI devices
Comment 5 Neil Horman 2008-12-11 11:29:02 EST
This is hardly a high priority bug.  We've lived without iscsi support since GA, we don't need to cram it in at the very last minute for 5.3, especially not such a large and complex patch

As far as the patch goes,  It looks ok, although it looks like you've duplicated some function.  As for the iscsi bits, it looks ok. I'll look more closely at this for 5.4
Comment 6 Neil Horman 2009-02-04 15:13:34 EST
I just reviewed this patch, and its just wrong.  It hacks in support for iscsi without any regard to how the other targets are handled.  I think this is going to have to be devel nak from me.  I've got an RFE for 5.4 for various other support requests, for which I'm developing an advanced configuration mode.  You'll be able to handle iscsi support from there.  This particular request is a WONTFIX from me

Note You need to log in before you can comment on or make changes to this bug.