Bug 476002 - When installing from fc10-DVD with repositories active, boot loader config is not updated
When installing from fc10-DVD with repositories active, boot loader config is...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
10
i686 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-11 09:54 EST by Mark Schaefer
Modified: 2009-09-09 05:59 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-09 05:59:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Schaefer 2008-12-11 09:54:21 EST
Description of problem:

I installed fc10 from DVD and CD on two CCISS servers, DL360 G3 and ML370 G2, both with CCISS controllers. The DVD allows selection of a repository during install.  If I select a repository that includes the latest kernel, the installer reports that no change was necessary to the boot loader. Upon restart, the kernel panics unable to find root (no initrd was created).  When I reinstalled and did not select the repositories, the initrd correctly included the cciss driver.

Version-Release number of selected component (if applicable):

10-DVD (and CD)

How reproducible:

Install on DL360 G3 or ML370 G2, enable fedora and fedora-updates repositories.

Steps to Reproduce:
1.  Insert CD into DL360 G3
2.  Reboot and install, making sure fedora and fedora-updates repositories are checked.
3.  Wait until end of install  (dialog is shown)
4.  Reboot - kernel panic and rescue shows that grub.conf includes no initrd.

Actual results:

Non-bootable installation

Expected results:

Bootable installation

Additional info:
Comment 1 Joel Andres Granados 2009-09-09 05:59:03 EDT
We have changed the process for creating the initrd.img.  We now use dracut now.  This issue seems to be addressed in current anaconda (12-21 or later).  Feel free to reopen this issue if you continue to see this behavior.

Note You need to log in before you can comment on or make changes to this bug.