Bug 476004 - [PATCH]: Fix phpize with libtool 2.2 in php 5.2.8
[PATCH]: Fix phpize with libtool 2.2 in php 5.2.8
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Remi Collet
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-11 09:59 EST by Nicholas Wourms
Modified: 2009-01-22 16:16 EST (History)
3 users (show)

See Also:
Fixed In Version: 5.2.8-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-22 16:16:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix phpize builds (637 bytes, patch)
2008-12-11 09:59 EST, Nicholas Wourms
no flags Details | Diff

  None (edit)
Description Nicholas Wourms 2008-12-11 09:59:08 EST
Created attachment 326627 [details]
Patch to fix phpize builds

(NOTE: I originally e-mailed Rex with this, Rex suggested I file a bug instead).

Description of problem:
The phpize script encounters autotools errors when used to build extensions

Version-Release number of selected component (if applicable):
5.2.8-1

How reproducible:
Always

Steps to Reproduce:
1. Install libtool 2.2
2. Install php 5.2.8
3. Attempt to rebuild the syck-0.61-6.1 package
  
Actual results:
Build of syck-0.61-6.1 fails on the php component because 

Expected results:
Build of syck-0.61-6.1 succeeds.

Additional info:
This is just a small patch to fix building php extensions outside of the php
build using phpize. The problem is that phpize's own build/libtool.m4
is missing autoconf macro definitions, due to the fact that libtool 2.2 now splits its macros into several files. In the specfile for php, there is a fix for using the new libtool for building the php package itself. However, the fix is not extended to the distributed libtools macro file used by phpize. To fix that, I have modified the specfile to concatenate all the the needed libtool 2.2 macros into build/libtool.m4, which is similar to the fix used building the php package itself with the new libtool. After applying this fix and installing the subsequent php packages, I am able to successfully rebuild syck-0.61-6.1.
Comment 1 Remi Collet 2008-12-13 03:50:50 EST
Thanks for the report

Patch applied in rawhide (5.2.8-2)
Comment 2 Nicholas Wourms 2008-12-13 14:14:40 EST
Could you rebuild the syck package against it?
Comment 3 Nicholas Wourms 2009-01-22 16:16:46 EST
I'm marking this closed since it has been in rawhide for awhile now with no further incident.

Note You need to log in before you can comment on or make changes to this bug.