Bug 476066 - Missing dependency on PackageKit-gtk-module
Missing dependency on PackageKit-gtk-module
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Dan Mashal
: Reopened
: 476120 (view as bug list)
Depends On:
Blocks: 668137
  Show dependency treegraph
 
Reported: 2008-12-11 14:05 EST by Horst H. von Brand
Modified: 2012-07-07 15:32 EDT (History)
23 users (show)

See Also:
Fixed In Version: PackageKit-0.7.5-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 668137 (view as bug list)
Environment:
Last Closed: 2012-07-07 15:32:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Horst H. von Brand 2008-12-11 14:05:59 EST
Description of problem:
Several programs complain (in this case dia):

  $ dia
  Gtk-Message: Failed to load module "pk-gtk-module": libpk-gtk-module.so: cannot open shared object file: No such file or directory

This is cured by installing PackageKit-gtk-module.

Version-Release number of selected component (if applicable):
gtk+-1.2.10-66.fc10.x86_64

How reproducible:
With many programs...

Steps to Reproduce:
1. dia
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Rex Dieter 2008-12-11 14:14:58 EST
I'd venture this was intended for gtk2.
Comment 2 Bill Nottingham 2008-12-11 14:56:09 EST
Is this a fatal error, or just a warning?
Comment 3 Horst H. von Brand 2008-12-11 15:00:43 EST
A warning
Comment 4 Horst H. von Brand 2008-12-11 15:02:40 EST
Sorry, depends. Some programs just don't work. For example, middle-click on an HTML attachment to an email in mh-e on xemacs just gives the above message, and doesn't show the attachment in firefox (as it should).
Comment 5 Matthias Clasen 2008-12-11 20:06:10 EST
GTK+ is just the messenger here. 

It fails to load the module, because the module is missing some dependency. Sounds more like a bug in library dependency handling in rpm. Or is the module not installed with the right permissions, so they don't get picked up ?
Comment 6 Richard Hughes 2008-12-12 04:43:09 EST
Matthias, the libpk-gtk-module.so file is shipped with PackageKit-gtk-module, and the autoload key is shipped with gnome-packagekit. In the future gnome-packagekit will depend on PackageKit-gtk-module -- but I've not added the dep yet as for the functionality to work it needs Behdads new fonconfig release before it does anything remotely useful. What I could do is add the dep, and change the default enabled gconf key to false in the spec file.
Comment 7 Matthias Clasen 2008-12-12 07:51:17 EST
Yeah, sound good enough.
Comment 8 Richard Hughes 2008-12-12 08:26:10 EST
commit 87e9007ead9d206d33b586594794b214f1b5b6a6
Author: Richard Hughes <richard@hughsie.com>
Date:   Fri Dec 12 13:24:53 2008 +0000

    trivial: make fedora spec file depend on PackageKit-gtk-module to fix rh#476066

I'll add the patch to set this to false by default now.
Comment 9 Richard Hughes 2008-12-12 08:51:32 EST
* Fri Dec 12 2008 Richard Hughes  <rhughes@redhat.com> - 0.4.0-2
- Depend on PackageKit-gtk-module so the auto-font installation can be
  turned on in F11.
- Turn off the loading of libpk-gtk-module.so until we have a new
  fontconfig using a spec file patch that we can nuke soon.
- Fixes rh#476066
Comment 10 Matthias Clasen 2008-12-13 14:22:47 EST
*** Bug 476120 has been marked as a duplicate of this bug. ***
Comment 11 Michael Cronenworth 2012-04-12 09:27:12 EDT
This is broken again.

Yes, it is "harmless" but it causes a bad user experience when they see error messages in their terminal.

It was broken by this commit:
http://pkgs.fedoraproject.org/gitweb/?p=gnome-packagekit.git;a=commit;h=8d23f39012f144fec7de0b3ef9daf6da73312f3a
Comment 12 Fernando Cassia 2012-04-12 11:27:38 EDT
Fedora 17 Beta RC3 here
 3.3.1-3.fc17.i686 #1 SMP Wed Apr 4 19:15:37 UTC 2012 i686 i686 i386 GNU/Linux

Starting the SeaMonkey browser suite 1.8
(seamonkey-2.8-3.fc17.i686)
I get:
Gtk-Message: Failed to load module "pk-gtk-module"

Package PackageKit-gtk3-module-0.7.3-1.fc17.i686 already installed and latest
version
Comment 13 Ankur Sinha (FranciscoD) 2012-04-16 16:12:58 EDT
Broken here too. 

Fedora 17 up to date as of today. 

Linux ankur.pc 3.3.1-5.fc17.x86_64 #1 SMP Tue Apr 10 20:42:28 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

PackageKit-gtk3-module.x86_64 0:0.7.3-1.fc17.

While it may be harmless, it keeps cropping up all the time :)

Thanks,
Ankur
Comment 14 fred 2012-04-26 16:34:31 EDT
Same bug crashes deja-dup when making backups.
Comment 15 Michael Cronenworth 2012-04-26 18:00:59 EDT
@fred, this bug does not induce crashes. You need to open a separate bug for deja-dup. The warning you see is completely harmless.
Comment 16 Yves L'ECUYER 2012-05-24 04:38:07 EDT
This bug IS NOT HARMLESS ?????
 
it has a deterring effect on any application using gtk lib and a non standard usage of stderror !

Typical example: Xdialog

all my administrative script with this GUI become unusable, unless a harrassing work in them, to turn around this BUG.

Just try any sample in /usr/share/doc/xdialog-2.3.1/samples
and you will see if it HAS NO EFFECT, because all the returned messages via the stderror are polluted by this message !!!

So peoples who want to continue to use Xdialog MUST do something like:
(example from radiolist programm in this sample directory)
SUBSTITUTE:
choice=`cat /tmp/checklist.tmp.$$`
BY:
choice=`cat /tmp/checklist.tmp.$$ | sed '/pk-gtk-module/ d' | xargs`
Comment 17 m 2012-06-01 14:10:46 EDT
dirty workaround (x86_64, adapt for x86) until it gets fix upstream

% wget http://dl.fedoraproject.org/pub/fedora/linux/releases/16/Fedora/x86_64/os/Packages/PackageKit-gtk-module-0.6.19-3.fc16.x86_64.rpm

% rpm2cpio PackageKit-gtk-module-0.6.19-3.fc16.x86_64.rpm | cpio -idmv

% sudo mv ./usr/lib64/gtk-2.0/modules/libpk-gtk-module.so /usr/lib64/gtk-2.0/modules/
Comment 18 Dan Mashal 2012-07-01 15:46:52 EDT
m,

Thanks for your workaround. this helped me tremendously. 

We need this library included back in to PackageKit-gtk3-module package or we need to create a new "PackageKit-gtk2-module" package. 

This is needed by many applications and "waiting for upstream" to port their applications to GTK3 is unacceptable.
Comment 19 Michael Cronenworth 2012-07-07 15:32:58 EDT
A dummy GTK2 module has been added to PackageKit-0.7.5-1.fc17.

Note You need to log in before you can comment on or make changes to this bug.