Bug 476089 - NetworkManager's policy selects wrong interface as default for routing and DNS
Summary: NetworkManager's policy selects wrong interface as default for routing and DNS
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 10
Hardware: i686
OS: Linux
low
high
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-12-11 21:11 UTC by yrtimiD
Modified: 2018-04-11 18:13 UTC (History)
7 users (show)

Fixed In Version: 0.7.0.99-1.fc10
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-03-08 19:32:43 UTC


Attachments (Terms of Use)
eifcfg-ethX configs and log output (11.52 KB, text/plain)
2008-12-11 21:11 UTC, yrtimiD
no flags Details
patch to fix ifcfg-rh nm-system-settings plugin which was incorrectly applying the IPADDR as the value of GATEWAY (1.31 KB, patch)
2009-01-08 04:30 UTC, Charles R. Anderson
no flags Details | Diff

Description yrtimiD 2008-12-11 21:11:09 UTC
Created attachment 326673 [details]
eifcfg-ethX configs and log output

Description of problem:
  I have two ethernet interfaces, eth0 connected to cable modem and eth1 has static IP and connected to the second PC (to allow internet access to the second PC).
  
  NetworkManager selects wrong network interface to be default for routing and DNS.

Version-Release number of selected component (if applicable):
  NetworkManager-0.7.0-0.12.svn4326.fc10.i386
  dhcp-4.0.0-33.fc10.i386
  dhclient-4.0.0-33.fc10.i386


How reproducible:
  Starting NetworkManager with both interfaces connected.

Steps to Reproduce:
1.service NetworkManager restart (start)
  
Actual results:
  route -n returns:
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.0.0     0.0.0.0         255.255.255.0   U     1      0        0 eth1
84.109.56.0     0.0.0.0         255.255.252.0   U     1      0        0 eth0
0.0.0.0         192.168.0.1     0.0.0.0         UG    0      0        0 eth1

Expected results:
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.0.0     0.0.0.0         255.255.255.0   U     1      0        0 eth1
84.109.56.0     0.0.0.0         255.255.252.0   U     0      0        0 eth0
169.254.0.0     0.0.0.0         255.255.0.0     U     1002   0        0 eth0
0.0.0.0         84.109.56.1     0.0.0.0         UG    0      0        0 eth0

Additional info:
In the attached file my ifcfg-ethX configs and output of NetworkManager to /var/log/messages

log has line:
NetworkManager: <info>  Policy set 'System eth1' (eth1) as default for routing and DNS
This looks wrong. is this "Policy" configurable? Why it selects eth1?

If I disable second interface (eth1) all works fine, and routes updated as expected.

Temporary fix for me: after NetworkManager started execute "ifdown eth0 && ifup eth0" - this fixes default gateway until eth1 connected or network is restarted.

Comment 1 Fedora Update System 2009-01-05 02:28:03 UTC
NetworkManager-0.7.0-1.git20090102.fc10,NetworkManager-vpnc-0.7.0-1.svn13.fc10,NetworkManager-openvpn-0.7.0-18.svn11.fc10,NetworkManager-pptp-0.7.0-1.svn16.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/NetworkManager-0.7.0-1.git20090102.fc10,NetworkManager-vpnc-0.7.0-1.svn13.fc10,NetworkManager-openvpn-0.7.0-18.svn11.fc10,NetworkManager-pptp-0.7.0-1.svn16.fc10

Comment 2 Fedora Update System 2009-01-05 02:30:01 UTC
NetworkManager-0.7.0-1.git20090102.fc9,NetworkManager-vpnc-0.7.0-1.svn13.fc9,NetworkManager-openvpn-0.7.0-18.svn11.fc9,NetworkManager-pptp-0.7.0-1.svn16.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/NetworkManager-0.7.0-1.git20090102.fc9,NetworkManager-vpnc-0.7.0-1.svn13.fc9,NetworkManager-openvpn-0.7.0-18.svn11.fc9,NetworkManager-pptp-0.7.0-1.svn16.fc9

Comment 3 Fedora Update System 2009-01-07 09:08:36 UTC
NetworkManager-0.7.0-1.git20090102.fc10, NetworkManager-vpnc-0.7.0-1.svn13.fc10, NetworkManager-openvpn-0.7.0-18.svn11.fc10, NetworkManager-pptp-0.7.0-1.svn16.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager NetworkManager-vpnc NetworkManager-openvpn NetworkManager-pptp'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-0023

Comment 4 Fedora Update System 2009-01-07 09:36:43 UTC
NetworkManager-0.7.0-1.git20090102.fc9, NetworkManager-vpnc-0.7.0-1.svn13.fc9, NetworkManager-openvpn-0.7.0-18.svn11.fc9, NetworkManager-pptp-0.7.0-1.svn16.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update NetworkManager NetworkManager-vpnc NetworkManager-openvpn NetworkManager-pptp'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2009-0222

Comment 5 Charles R. Anderson 2009-01-07 14:53:32 UTC
I'm seeing something similar.  eth1 in my case has no default gateway configured, but NM makes one up and selects it to use for the default.  I'll test the updated packages above.

Comment 6 Fedora Update System 2009-01-08 04:17:42 UTC
NetworkManager-0.7.0-1.git20090102.fc10, NetworkManager-vpnc-0.7.0-1.svn13.fc10, NetworkManager-openvpn-0.7.0-18.svn11.fc10, NetworkManager-pptp-0.7.0-1.svn16.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Charles R. Anderson 2009-01-08 04:30:50 UTC
Created attachment 328436 [details]
patch to fix ifcfg-rh nm-system-settings plugin which was incorrectly applying the IPADDR as the value of GATEWAY

NetworkManager-0.7.0-1.git20090102.fc10 does NOT fix the issue for me, but this patch does.

Comment 8 Matěj Cepl 2009-01-19 15:08:58 UTC
DNS part of this issue is still unresolved, but it is duplicate of bug 459961.

Comment 9 Fedora Update System 2009-02-07 22:22:18 UTC
NetworkManager-0.7.0-2.git20090207.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-1471

Comment 10 yrtimiD 2009-02-13 15:55:04 UTC
NetworkManager-0.7.0-2.git20090207.fc10 solved my default routing problem.

Comment 11 Fedora Update System 2009-02-24 20:49:32 UTC
NetworkManager-0.7.0.97-5.git20090220.fc10, NetworkManager-openconnect-0.7.0.97-1.fc10, NetworkManager-pptp-0.7.0.97-1.fc10, NetworkManager-openvpn-0.7.0.97-1.fc10, NetworkManager-vpnc-0.7.0.97-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager NetworkManager-openconnect NetworkManager-pptp NetworkManager-openvpn NetworkManager-vpnc'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-1985

Comment 12 Fedora Update System 2009-02-28 03:24:04 UTC
NetworkManager-0.7.0.98-1.git20090225.fc10, NetworkManager-openconnect-0.7.0.97-1.fc10, NetworkManager-pptp-0.7.0.97-1.fc10, NetworkManager-openvpn-0.7.0.97-1.fc10, NetworkManager-vpnc-0.7.0.97-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager NetworkManager-openconnect NetworkManager-pptp NetworkManager-openvpn NetworkManager-vpnc'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-1985

Comment 13 Fedora Update System 2009-03-06 17:34:27 UTC
NetworkManager-0.7.0.99-1.fc10,knetworkmanager-0.7-0.8.20080926svn.fc10,NetworkManager-vpnc-0.7.0.99-1.fc10,NetworkManager-openvpn-0.7.0.99-1.fc10,NetworkManager-pptp-0.7.0.99-1.fc10,NetworkManager-openconnect-0.7.0.99-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/NetworkManager-0.7.0.99-1.fc10,knetworkmanager-0.7-0.8.20080926svn.fc10,NetworkManager-vpnc-0.7.0.99-1.fc10,NetworkManager-openvpn-0.7.0.99-1.fc10,NetworkManager-pptp-0.7.0.99-1.fc10,NetworkManager-openconnect-0.7.0.99-1.fc10

Comment 14 Fedora Update System 2009-03-06 17:50:52 UTC
NetworkManager-0.7.0.99-1.fc9,NetworkManager-vpnc-0.7.0.99-1.fc9,NetworkManager-openvpn-0.7.0.99-1.fc9,NetworkManager-pptp-0.7.0.99-1.fc9,NetworkManager-openconnect-0.7.0.99-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/NetworkManager-0.7.0.99-1.fc9,NetworkManager-vpnc-0.7.0.99-1.fc9,NetworkManager-openvpn-0.7.0.99-1.fc9,NetworkManager-pptp-0.7.0.99-1.fc9,NetworkManager-openconnect-0.7.0.99-1.fc9

Comment 15 Fedora Update System 2009-03-08 19:29:25 UTC
NetworkManager-0.7.0.99-1.fc9, NetworkManager-vpnc-0.7.0.99-1.fc9, NetworkManager-openvpn-0.7.0.99-1.fc9, NetworkManager-pptp-0.7.0.99-1.fc9, NetworkManager-openconnect-0.7.0.99-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2009-03-08 19:31:18 UTC
NetworkManager-0.7.0.99-1.fc10, knetworkmanager-0.7-0.8.20080926svn.fc10, NetworkManager-vpnc-0.7.0.99-1.fc10, NetworkManager-openvpn-0.7.0.99-1.fc10, NetworkManager-pptp-0.7.0.99-1.fc10, NetworkManager-openconnect-0.7.0.99-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 John Southworth 2009-04-20 21:25:05 UTC
I'm experiencing a similar problem using NetworkManager-openvpn. When I set the openvpn server to push the default route the client gives the following error
Apr 20 15:13:26 janos-t62 NetworkManager: <WARN>  nm_system_replace_default_ip4_route_vpn(): (tun0): failed to set IPv4 default route (pass #2): -3

I believe the last set of updates created the problem, because it worked fine before I applied them.

I currently have these packages installed:
NetworkManager-gnome-0.7.0.99-5.git20090326.fc10.i386
NetworkManager-pptp-0.7.0.99-1.fc10.i386
NetworkManager-0.7.0.99-5.git20090326.fc10.i386
NetworkManager-openvpn-0.7.0.99-1.fc10.i386
NetworkManager-vpnc-0.7.0.99-1.fc10.i386
NetworkManager-glib-0.7.0.99-5.git20090326.fc10.i386
NetworkManager-openconnect-0.7.0.99-2.fc10.i386


Note You need to log in before you can comment on or make changes to this bug.