Bug 476091 - IcedTea plugin does not work with konqueror
IcedTea plugin does not work with konqueror
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Deepak Bhole
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-11 16:15 EST by Deepak Bhole
Modified: 2009-02-24 15:12 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-24 15:12:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Deepak Bhole 2008-12-11 16:15:14 EST
IcedTea plugin is not detected or usable by konqueror. There is no reason why it shouldn't work, and this issue should be looked into.
Comment 1 Omair Majid 2009-02-23 14:43:07 EST
Konqueror uses NPAPI to support mozilla plugins. IcedTea plugin relies on the LiveConnect api to work which makes it incompatible with konqueror.

However, Konqueror supports java applets through KDE Java Applet Server (KJAS). Please see http://www.konqueror.org/javahowto/ for details. Here are the steps to get Java working with konqueror:
1. Make sure you have a JRE/JDK installed
2. In konqueror, select Settings->Configure Konqueror
3. Select 'Java & JavaScript' under Web Browsing.
4. On the Java tab, check 'Enable Java Globally'
5. Set the 'Path to Java executable' to '/usr/bin/java', or to your JRE's java program (the documentation says that the defualt 'java' should work, but it doesnt seem to)
Comment 2 Deepak Bhole 2009-02-24 15:12:23 EST
Since konqueror has no OJI support, getting IcedTeaPlugin work to with it would be pretty much impossible without a significant rewrite to use NPAPI. Closing this as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.