Bug 476098 - wings.fc10 does not start
wings.fc10 does not start
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: wings (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Gérard Milmeister
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-11 17:42 EST by François Cami
Modified: 2008-12-17 19:36 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-17 19:36:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to fix the spec file (400 bytes, patch)
2008-12-11 17:43 EST, François Cami
no flags Details | Diff

  None (edit)
Description François Cami 2008-12-11 17:42:17 EST
Description of problem:
wings does not start in fc10.
this is due to a missing parameter in the /usr/bin/wings script.

Version-Release number of selected component (if applicable):
wings-0.99.02-2.fc10.x86_64

How reproducible:
always

Steps to Reproduce:
on a dualcore x86_64 PC :
1. # yum -y install wings
2. $ wings
  
Actual results:
$ wings
erlexec: Error 2 executing '/usr/lib64/wings/bin/beam.smp'.

Expected results:
wings window appear...

Additional info:
The correct executable is beam, not beam.smp .
This is due to a missing parameter in the /usr/bin/wings script, documented in the original sources, see wings-0.99.02/unix/install_wings.src .

The attached patch fixes the spec file and makes wings run again.
Comment 1 François Cami 2008-12-11 17:43:43 EST
Created attachment 326686 [details]
patch to fix the spec file
Comment 2 Gérard Milmeister 2008-12-12 01:58:50 EST
This is strange.
The spec file already has

exec \$BINDIR/erlexec -smpdisable -noinput -run wings_start start_halt \$*
Comment 3 François Cami 2008-12-12 02:12:20 EST
wings has not been rebuilt for F10 with this fix, see Koji :
http://koji.fedoraproject.org/koji/packageinfo?packageID=4108

I've just rebuilt wings-0.99.05-2.fc9 on my F10 box and it works just fine.

Could you please rebuild for F10 and push ?

Thanks
Comment 4 François Cami 2008-12-12 15:29:28 EST
Gérard, wings-0.99.05-2.fc10.x86_64 built today in koji fixes the bug:
http://koji.fedoraproject.org/koji/buildinfo?buildID=74416 .

Switching to Verified.
Comment 5 Fedora Update System 2008-12-13 18:24:49 EST
wings-0.99.05-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/wings-0.99.05-2.fc10
Comment 6 Fedora Update System 2008-12-17 19:36:48 EST
wings-0.99.05-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.