Bug 476164 - block detaching causes issues in xend if the device is in use by the domain
block detaching causes issues in xend if the device is in use by the domain
Status: CLOSED DUPLICATE of bug 484110
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.3
All Linux
high Severity high
: rc
: ---
Assigned To: Michal Novotny
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-12 02:00 EST by Gurhan Ozen
Modified: 2014-02-02 17:36 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Red Hat advises that you avoid removing a block device from a guest when the device is in use. Doing so causes Xend to lose domain information for the guest.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-05 06:18:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gurhan Ozen 2008-12-12 02:00:17 EST
Description of problem:

  When a device is attached to the guest, if it's in use by the guest while it's detached, then xend loses the domain and no operations can be done on the guest from dom0.

  Guests, in this case, seem to be alive, i.e. if you have connected to the console of the guest before the you can still control the guest, however from dom0 you can't do anything on the guest and xend.log gives errors for not being able to query SXPR for domain.

Version-Release number of selected component (if applicable):
# rpm -qa | grep xen 
xen-devel-3.0.3-79.el5
xen-devel-3.0.3-79.el5
xen-libs-3.0.3-79.el5
xen-3.0.3-79.el5
xen-debuginfo-3.0.3-79.el5
kernel-xen-2.6.18-126.el5
xen-debuginfo-3.0.3-79.el5
kernel-xen-devel-2.6.18-126.el5
xen-libs-3.0.3-79.el5


How reproducible:
Very.

Steps to Reproduce:
1. Install 5.3 dom0 / guests. 
2. Attach a disk to the guest. Go into the guest and mount the device 
3. Detach the disk from the guest on dom0 while it's mounted in the guest.
  
Actual results:
Xend loses domaininfo for the guest.

Additional info:
This was on an x86_64 dom0 with x86_64 pv, x86_64 hvm and i386 hvm guests. I used all tap:aio drivers for these tests.
Comment 2 Bill Burns 2008-12-16 11:41:07 EST
Providing release note text.

It is not recommend to remove a block device from a guest when
that device is in use. Doing so causes Xend to lose domaininfo
for the guest.
Comment 3 Bill Burns 2008-12-16 11:41:07 EST
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
It is not recommend to remove a block device from a guest when that device is in use. Doing so causes Xend to lose domain info for the guest.
Comment 4 Don Domingo 2009-01-13 22:59:34 EST
Release note updated. If any revisions are required, please set the 
"requires_release_notes"  flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

Diffed Contents:
@@ -1 +1 @@
-It is not recommend to remove a block device from a guest when that device is in use. Doing so causes Xend to lose domain info for the guest.+Red Hat advises that you avoid removing a block device from a guest when the device is in use. Doing so causes Xend to lose domain information for the guest.
Comment 6 Michal Novotny 2009-03-05 06:18:03 EST

*** This bug has been marked as a duplicate of bug 484110 ***
Comment 7 Michal Novotny 2009-03-05 06:20:15 EST
Sorry, forget to add comment here. Anyway when looking at this bug and steps to reproduce this is what was found when solving bug #484110 and corrected. Patch for this is available there (in bug patches for #484110).

Note You need to log in before you can comment on or make changes to this bug.