Bug 476210 - Revisor does not run with SELinux in enforcing mode
Revisor does not run with SELinux in enforcing mode
Status: CLOSED DUPLICATE of bug 455744
Product: Fedora
Classification: Fedora
Component: revisor (Show other bugs)
10
All Linux
low Severity urgent
: ---
: ---
Assigned To: Jeroen van Meeuwen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-12 09:15 EST by Josef Bacik
Modified: 2009-04-04 14:19 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-05 23:43:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josef Bacik 2008-12-12 09:15:31 EST
Description of problem:
Whenever I try to run Revisor with SELinux in enforcing mode I get this pop up that reads

"SELinux is in enforcing mode on this host. Composing media will fail. Please set SELinux to permissive mode."

So a Fedora specific application that doesn't work with SELinux turned on?  Really this isn't FC2 anymore, this should not be a problem.  Maybe in Alpha/Beta, but by release these sort of things should really be fixed.

I'd file this under SELinux normally, but the problem is Revisor doesn't even run if it detects that the box has SELinux in enforcing mode, which is complete crap.  If SELinux does get in the way I should at least be able to use audit2allow to make it work, but I don't even have that option.

Version-Release number of selected component (if applicable):
(josef@unused)(189/pts/4)(09:13am:12/12/08)-
(%:~)- rpm -q revisor
revisor-2.1.3-1.fc10.noarch


How reproducible:
Every time

Steps to Reproduce:
1. Turn SELinux on enforcing
2. Try to run Revisor
  
Actual results:
Does not run, complains about SELinux being in enforcing mode

Expected results:
Should just work.
Comment 1 Fedora Admin XMLRPC Client 2009-01-31 19:05:53 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Jerry Amundson 2009-03-05 23:43:45 EST

*** This bug has been marked as a duplicate of bug 455744 ***

Note You need to log in before you can comment on or make changes to this bug.