Bug 476215 - Find and replace doesn't work in calc
Find and replace doesn't work in calc
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-12 10:17 EST by Linuxguy123
Modified: 2009-01-16 07:20 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-16 07:20:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
State before 'Search and Replace' (11.89 KB, application/octet-stream)
2008-12-17 09:48 EST, David Tardon
no flags Details
State after 'Search and Replace' (11.57 KB, application/octet-stream)
2008-12-17 09:49 EST, David Tardon
no flags Details
calc file with numbers using the comma format (11.11 KB, application/vnd.oasis.opendocument.spreadsheet)
2008-12-18 15:55 EST, Linuxguy123
no flags Details

  None (edit)
Description Linuxguy123 2008-12-12 10:17:17 EST
Description of problem:

Multi cell find and replace doesn't work in open-office calc.

Version-Release number of selected component (if applicable):

$ yum list openoffice.org-calc*
Loaded plugins: downloadonly, kmdl, priorities, refresh-packagekit
0 packages excluded due to repository priority protections
Installed Packages
openoffice.org-calc.i386                                                        1:3.0.0-9.10.fc10                                                    installed
openoffice.org-calc-core.i386                                                   1:3.0.0-9.10.fc10                                                    installed

How reproducible:
I have not been able to make it work once.

Steps to Reproduce:

1. Import data with a format that uses commas instead of periods.  It imports correctly. 

2. Select a bunch of cells.  Select Find and Replace

3. Set Search for "," and Replace with ".".  Press Find or Replace or Replace all.  
  
Actual results:

Nothing happens.  Nothing gets replaced.  

If you close the Find and Replace dialog window and open it again, it keeps the ",", but loses the "."


Expected results:
It should replace all the ","s with "."s.  I have to do it by hand now. 


Additional info:

I got the data by copying and pasting the motor data table from here:

http://www.icare-rc.com/plettenberg_predator.htm
Comment 1 Caolan McNamara 2008-12-14 10:39:13 EST
I suggest that you attach a sample .ods of the state before search & replace for me to have a look at it.

i.e. in my locale the decimal mark is "." so strings like 88,5 will import as "text" and so I can easily search and replace them with the dialog.

But if your locale is one that uses "," instead of "." then I would definitely expect that the search and replaces wouldn't do anything as the "," isn't really there to be replaced, instead if is just the way that decimals are displayed in that locale.

So I can't be sure if the problem here is one of "I can't search and replace , to be . in a text cell" or if its is "I want to change what is displayed for decimal separators". If it was the second, then e.g. format cell language and change it to an English locale would change the , to .
Comment 2 David Tardon 2008-12-17 09:47:39 EST
It works for me, too. I tried it in Czech locale (cs_CZ.utf8) that uses comma as decimal mark. I selected the table on the HTML page and inserted it into an empty sheet; the numbers were correctly imported as numbers. Then I selected body of the table and performed the replace; all numbers containing a comma were converted to text and the commas were replaced by dots.
Comment 3 David Tardon 2008-12-17 09:48:47 EST
Created attachment 327253 [details]
State before 'Search and Replace'
Comment 4 David Tardon 2008-12-17 09:49:20 EST
Created attachment 327254 [details]
State after 'Search and Replace'
Comment 5 Linuxguy123 2008-12-18 15:55:19 EST
Created attachment 327364 [details]
calc file with numbers using the comma format

Try searching the voltage, current and efficiency columns and replacing the "," with "."s.
Comment 6 David Tardon 2008-12-19 04:10:43 EST
It does work for me, in both English and Czech locale. Have you got any 'unusual' language settings? Have you got any field checked under 'More options' it the Search and Replace dialog?
Comment 7 Linuxguy123 2008-12-19 08:57:43 EST
It just worked for me.   I have no idea why it didn't work before. 

I am working in English.  I don't have any unusual language settings.   I didn't have anything selected under "More options".

I think there is a bug here, but I can't replicate it now.  I'll play around with it later and see if I can get it to do it again.
Comment 8 Caolan McNamara 2009-01-16 07:20:06 EST
Lets close it for now then

Note You need to log in before you can comment on or make changes to this bug.