Bug 476221 - psprint.conf should be flagged as a config file in openoffice.org-core RPM
psprint.conf should be flagged as a config file in openoffice.org-core RPM
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: openoffice.org (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Caolan McNamara
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-12 10:43 EST by Dan Astoorian
Modified: 2009-09-02 05:09 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 05:09:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Astoorian 2008-12-12 10:43:03 EST
+++ This bug was initially created as a clone of Bug #476220 +++

Description of problem:
The spec file for the openoffice.org-core RPM does not flag the file /usr/{lib,lib64}/openoffice.org/share/psprint/psprint.conf as a configuration file.  As a result, upgrading the package results in the machine's printer configuration being overwritten.

Version-Release number of selected component (if applicable):
openoffice.org-core-2.3.0-6.5.4.el5_2 and earlier

How reproducible:
Always

Steps to Reproduce:
1. add a global printer to OOo2 (e.g., using /usr/{lib,lib64}/openoffice.org/program/spadmin as root)
2. upgrade or reinstall the openoffice.org-core RPM

  
Actual results:
The new printer is no longer present, since the file /usr/{lib,lib64}/openoffice.org/share/psprint/psprint.conf is replaced with the file from the new RPM.

Expected results:
The new printer should be preserved.

Additional info:
This defect also applies to Red Hat Enterprise Linux 4 (cf. Bug #476220).
Comment 1 Caolan McNamara 2008-12-14 10:07:42 EST
FWIW It is not recommended to use spadmin to add a printer that OOo alone can use, just use the normal desktop printer adding software. spadmin really only exists for the moment in RHEL to give a way to support fax numbers for printing direct to fax.
Comment 2 Dan Astoorian 2008-12-15 11:07:05 EST
Okay, then /usr/{lib,lib64}/openoffice.org/share/psprint/psprint.conf should be marked as a configuration file so that the fax printers defined in that file don't get removed when OpenOffice is updated.

At our site we need to add printers via psprint.conf because we cannot use CUPS for printing due to its lack of support for user authentication.  (E.g.: the GTK2 CUPS print backend does not work at all when any type of CUPS authentication is enabled; cf. bug #476232.)

Conversely, I don't see a downside to marking psprint.conf as a config file in the RPM.
Comment 3 Caolan McNamara 2009-02-05 18:28:48 EST
In general I think this is a bad idea to need to modify the OOo config specifically to hackaround a problem, i.e. problems still persist for e.g. evince and the rest of the desktop stack.

That said, it doesn't hurt to be able to at least print from OOo.
Comment 4 Dan Astoorian 2009-02-05 19:07:01 EST
Yes, needing to modify the OOo config to work around a problem is less than ideal; however, being unable to do so where no better solution exists is worse.

psprint.conf is, by its suffix, clearly a configuration file: if the user customizes it (irrespective of whether that customization is recommended or not), it is difficult to understand how destroying these customizations during a package update can be the right thing to do.
Comment 5 Caolan McNamara 2009-03-12 07:18:38 EDT
checked in for >= 2.3.0-6.11
Comment 9 errata-xmlrpc 2009-09-02 05:09:05 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1248.html

Note You need to log in before you can comment on or make changes to this bug.