Bug 476236 - kernel-debug should be provided or obsoleted
kernel-debug should be provided or obsoleted
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-12 11:53 EST by Christopher Beland
Modified: 2009-02-24 20:18 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-24 20:18:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Beland 2008-12-12 11:53:09 EST
After a "yum update" yesterday, I have the following kernel-related RPMs installed (from "rpm -qa | grep kernel | sort"):

kernel-debug-2.6.27.5-117.fc10.x86_64
kernel-debug-debuginfo-2.6.27.5-117.fc10.x86_64
kernel-debuginfo-2.6.27.5-117.fc10.x86_64
kernel-debuginfo-common-2.6.27.5-117.fc10.x86_64
kernel-firmware-2.6.28-0.121.rc7.git5.fc11.noarch
kernel-headers-2.6.28-0.121.rc7.git5.fc11.x86_64

Michael Schwendt notes that "kernel-debug" has disappeared from the recent build:

http://koji.fedoraproject.org/koji/buildinfo?buildID=73968

compared to the F10 build:

http://koji.fedoraproject.org/koji/buildinfo?buildID=70131

I use "kernel-debug" instead of "kernel" so that I can provide useful debugging information to Red Hat developers when I experience a kernel oops.  If "kernel-debug" is still necessary for this purpose, it would be nice to get it back.  If "kernel" is sufficient, it would be nice if it were packaged in such a way that "kernel-debug" is obsoleted and eventually removed (or at least "kernel" is installed when an upgrade to "kernel-debug" is requested).

Thanks!
Comment 1 Christopher Beland 2008-12-12 12:12:38 EST
I'm updating manually to work around this, and I had to remove kernel-debug-debuginfo before I was able to get yum to update kernel-debuginfo.  Apparently they both depend on kernel-debuginfo-common.  Something else to check when getting this to work automatically if kernel-debug is no longer needed.
Comment 2 Kyle McMartin 2009-02-24 20:18:48 EST
If you're running rawhide (F11) then you won't have a kernel-debug until very close to release, because all kernels are implicitly debug kernels.

You've kind of dug yourself into your own hole here, by removing the plain kernel package... They should be coinstallable and I suspect Providing or Obsoleting would cause an issue there. Closing NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.