Bug 476238 - Version of kernel-headers and kernel-firmware must sync with installed kernel
Version of kernel-headers and kernel-firmware must sync with installed kernel
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-12 11:59 EST by Christopher Beland
Modified: 2009-03-26 14:09 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-26 14:09:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Beland 2008-12-12 11:59:08 EST
After a "yum update" yesterday, I have the following kernel-related RPMs installed (from "rpm -qa | grep kernel | sort"):

kernel-debug-2.6.27.5-117.fc10.x86_64
kernel-debug-debuginfo-2.6.27.5-117.fc10.x86_64
kernel-debuginfo-2.6.27.5-117.fc10.x86_64
kernel-debuginfo-common-2.6.27.5-117.fc10.x86_64
kernel-firmware-2.6.28-0.121.rc7.git5.fc11.noarch
kernel-headers-2.6.28-0.121.rc7.git5.fc11.x86_64

Note that the version number of kernel-firmware and kernel-headers got out of sync with kernel-debug.  (I use that instead of kernel so I can provide useful reports on kernel oopses.)  It's my understanding that the version numbers need to be in sync for things to work properly, so yum shouldn't have been able to do that.
Comment 1 Chuck Ebbert 2008-12-15 05:09:20 EST
This bug is reported against Fedora 9, however:

  The Fedora 10 kernel is installed.

  Parts of the Rawhide (Fedora 11) kernel are installed.

How did things get like that?
Comment 2 Christopher Beland 2008-12-15 10:11:38 EST
Sorry, this should have been filed against rawhide.  I've been updating it using only "yum update" since F10 snap 3, I think.
Comment 3 Chuck Ebbert 2009-02-10 02:25:24 EST
The kernel-firmware version must be equal to or greater than the version of all installed kernels.
Comment 4 Kyle McMartin 2009-02-26 14:35:33 EST
If you're running rawhide, there is no kernel-debug, so of course they got out of sync...

Note You need to log in before you can comment on or make changes to this bug.