Bug 476273 - (CVE-2008-5504) CVE-2008-5504 Firefox 2 XSS attack vectors in feed preview
CVE-2008-5504 Firefox 2 XSS attack vectors in feed preview
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Red Hat Product Security
: Security
Depends On:
  Show dependency treegraph
Reported: 2008-12-12 15:38 EST by Josh Bressers
Modified: 2016-03-04 06:51 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2010-12-25 11:58:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Josh Bressers 2008-12-12 15:38:11 EST
Mozilla security researcher moz_bug_r_a4 reported that the fix for a series
of feedWriter vulnerabilities published in a previous security update was
incomplete. moz_bug_r_a4 demonstrated that it was still possible to use the
feed preview as a vector for JavaScript privilege escalation. An attacker
could use this issue to run arbitrary JavaScript with chrome privileges.
Comment 2 Josh Bressers 2008-12-16 18:26:36 EST
This is now public:
Comment 3 Fedora Update System 2008-12-21 03:42:22 EST
firefox-, epiphany-2.20.3-9.fc8, epiphany-extensions-2.20.1-12.fc8, blam-1.8.3-20.fc8, cairo-dock-, chmsee-1.0.0-6.31.fc8, devhelp-0.16.1-12.fc8, evolution-rss-0.0.8-14.fc8, galeon-2.0.4-7.fc8.3, gnome-python2-extras-2.19.1-20.fc8, gnome-web-photo-0.3-15.fc8, kazehakase-0.5.6-1.fc8.2, liferea-1.4.15-6.fc8, Miro-1.2.7-3.fc8, openvrml-0.17.10-3.0.fc8, ruby-gnome2-0.17.0-4.fc8, yelp-2.20.0-15.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 4 Vincent Danen 2010-12-25 11:58:07 EST
This was addressed via:
Red Hat Enterprise Linux version 2.1 (seamonkey) RHSA-2008:1037
Red Hat Enterprise Linux version 3 (seamonkey) RHSA-2008:1037
Red Hat Enterprise Linux version 4 (seamonkey) RHSA-2008:1037

Note You need to log in before you can comment on or make changes to this bug.