Bug 476277 - [PATCH] After install will not boot from i2o subsystem
[PATCH] After install will not boot from i2o subsystem
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11Blocker/F11FinalBlocker
  Show dependency treegraph
 
Reported: 2008-12-12 15:44 EST by Hibbard T. Smith, JR
Modified: 2009-03-31 15:05 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-16 14:48:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to mkinitrd-6.0.71 to resolve i2o boot disk problem. (679 bytes, text/plain)
2008-12-12 15:44 EST, Hibbard T. Smith, JR
no flags Details

  None (edit)
Description Hibbard T. Smith, JR 2008-12-12 15:44:24 EST
Created attachment 326771 [details]
Patch to mkinitrd-6.0.71 to resolve i2o boot disk problem.

Description of problem: After installing F10 from the final release DVD to a boot disk on an i2o subsystem, the system will not boot. 

This system is a Supermicro X5DA8 and uses an Adaptec ASR2010S ZCR controller for the system drives in RAID 5 mode.

The system will not boot after the install because intrd does not contain the i2o_block driver.  I previously reported this problem under F9 (BUG #466491), but very near the release of F10.  I submitted a patch to mkinitrd which resolved the issue for my system.  

It looks like a change was made for mkinitrd-6.0.71 for F10, but it does not work.  I'm submitting a patch to mkinitrd-6.0.71 which does resolve the problem on my system.  It simply reverses the sense of the change that was made.

In scanning various Fedora and linux discussion, it appears that some others are having this problem also.  An official fix would be very worthwhile.

Thanks, in advance, for your attention.


Version-Release number of selected component (if applicable): 6.0.71


How reproducible: Always fails.


Steps to Reproduce:
1. Install F10
2. System will not boot
3.
  
Actual results: System will not boot.


Expected results:


Additional info:
Comment 1 Hibbard T. Smith, JR 2008-12-19 08:56:07 EST
I guess I don't understand why this is assigned a low priority.  This problem prevented me (and probably others) from using Fedora 6, 7 and 8.  I finally decided to resolve it myself for 9 and submitted a bug bug report with a patch ( bug #466491 ). This was never even afforded the courtesy of a response.  Since mkinitrd changed for 10, I had to resolve it again and submitted this bug report  with a patch.  Again the priority has been set to low and this bug report seems to be being ignored.  Since this is most likely affecting anyone who tries to use an i2o based RAID as the system disk, and there are other complaints of the same issue in the various discussion groups, I don't understand why it can't be addressed.
Comment 2 Hibbard T. Smith, JR 2008-12-19 09:21:13 EST
I guess I don't understand why this is assigned a low priority.  This problem prevented me (and probably others) from using Fedora 6, 7 and 8.  I finally decided to resolve it myself for 9 and submitted a bug bug report with a patch ( bug #466491 ). This was never even afforded the courtesy of a response.  Since mkinitrd changed for 10, I had to resolve it again and submitted this bug report  with a patch.  Again the priority has been set to low and this bug report seems to be being ignored.  Since this is most likely affecting anyone who tries to use an i2o based RAID as the system disk, and there are other complaints of the same issue in the various discussion groups, I don't understand why it can't be addressed.
Comment 3 Hibbard T. Smith, JR 2008-12-19 09:22:58 EST
Sorry for the double add of this comment.  In a moment of stupidity, I clicked on refresh in my browser window.  That had the effect of adding the comment again.  

Sorry, I really didn't mean to say it twice.
Comment 4 Dave Hopkins 2009-03-07 20:09:38 EST
Thank you! Thank you! Thank you!!!!!!!  I also have this issue when trying to install from the DVD, the CD set, or the live DVD.  The fix submitted allowed me to recreate the initrd img and boot the system.  I have 7 servers that use the Adaptec 2010s zero channel card and like Mr. Smith I also have not been able to use Fedora on these systems for years.  Please implement this patch, it works!

Sincerely,
Dave Hopkins
Comment 5 Hans de Goede 2009-03-16 14:48:11 EDT
This is fixed in mkinitrd-6.0.81, which should be in tomorrows rawhide.
Comment 6 Hans de Goede 2009-03-31 15:05:52 EDT
Hi All,

So as you may have heared the storage code in anaconda (the installer) has been completely rewritten from scratch for Fedora 11.

Unfortunately non of us has direct (physical) access to an i2o using machine. Thus a kind request: can you please try to install F-11 beta (just released) on your i20 machine(s), on a spare partition for example ? And tell us if the new code works with i2o or not?

Note You need to log in before you can comment on or make changes to this bug.