Bug 476288 - Evolution crashs when asigning a signature to an imap account
Evolution crashs when asigning a signature to an imap account
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-12 16:01 EST by Heiko Adams
Modified: 2008-12-14 18:16 EST (History)
2 users (show)

See Also:
Fixed In Version: evolution-2.24.2-2.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-14 18:16:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Heiko Adams 2008-12-12 16:01:56 EST
Description of problem:
When assigning a signature to an imap account, evolution crashs.

Version-Release number of selected component (if applicable):
evolution-2.24.2-1.fc10.i386

How reproducible:
allwas

Steps to Reproduce:
1. Open the preferences of an imap account
2. Assign a signature
3. Save changes
  
Actual results:
evolution crashs

Expected results:
evolution shouldn't crash

Additional info:
Comment 1 Matthew Barnes 2008-12-12 16:26:41 EST
Thanks for taking the time to report this bug.
Without a stack trace from the crash it's very hard to determine what caused it.
Can you get us a stack trace? Please see http://live.gnome.org/GettingTraces for more information on how to do so. Thanks in advance!
Comment 2 Heiko Adams 2008-12-12 17:46:55 EST
I've submitted a strack trace via bug-boddy. Bug-boddy told me http://crash.gnome.org/report/index/7493bfd8-c89e-11dd-ad92-0007e9333148?date=2008-12-12-22 as url
Comment 3 Heiko Adams 2008-12-14 16:38:50 EST
Since the URL returns an 530 error these are the crash-details:

Distribution: Fedora release 10 (Cambridge)
Gnome Release: 2.24.2 2008-11-25 (Red Hat, Inc)
BugBuddy Version: 2.24.2

System: Linux 2.6.27.7-134.fc10.i686 #1 SMP Mon Dec 1 22:42:50 EST 2008 i686
X Vendor: The X.Org Foundation
X Vendor Release: 10503000
Selinux: Enforcing
Accessibility: Disabled
GTK+ Theme: Nodoka
Icon Theme: Fedora

Memory status: size: 0 vsize: 0 resident: 0 share: 0 rss: 0 rss_rlim: 0
CPU usage: start_time: 0 rtime: 0 utime: 0 stime: 0 cutime:0 cstime: 0 timeout: 0 it_real_value: 0 frequency: 0



----------- .xsession-errors ---------------------
(evolution:6162): Gtk-CRITICAL **: gtk_box_pack: assertion `child->parent == NULL' failed
(evolution:6162): GLib-GObject-WARNING **: invalid cast from `GtkButton' to `GtkMisc'
(evolution:6162): Gtk-CRITICAL **: gtk_misc_set_alignment: assertion `GTK_IS_MISC (misc)' failed
(evolution:6162): Gtk-CRITICAL **: gtk_box_pack: assertion `child->parent == NULL' failed
(evolution:6162): Gtk-CRITICAL **: gtk_box_pack: assertion `child->parent == NULL' failed
(evolution:6162): Gtk-CRITICAL **: gtk_box_pack: assertion `child->parent == NULL' failed
(evolution:6162): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated
(evolution:6162): e-data-server-CRITICAL **: e_account_set_string: assertion `ea != NULL' failed
--------------------------------------------------
Comment 4 Matthew Barnes 2008-12-14 17:19:25 EST
Thanks, but this information still doesn't contain a stack trace.  Can you try pasting the crash report directly from Bug Buddy?  (crash.gnome.org is rather useless, unfortunately.)

Also please make sure you have debugging information installed before posting the crash report.  (run "debuginfo-install evolution" as root)

Thanks in advance.
Comment 5 Matthew Barnes 2008-12-14 17:21:27 EST
Also, you might try updating to evolution-2.24.2-2.fc10.

That updated fixed a serious bug that's been causing all kinds of strange side effects.  The crash you're seeing might be one of those side effects.
Comment 6 Heiko Adams 2008-12-14 18:02:19 EST
Updating to evolution-2.24.2-2.fc10 solved this problem. Thanks for the fast help.
Comment 7 Matthew Barnes 2008-12-14 18:16:39 EST
Thanks for the update.

Note You need to log in before you can comment on or make changes to this bug.