Bug 476292 - Bad name for webcam microphone
Bad name for webcam microphone
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-12 16:10 EST by Bastien Nocera
Modified: 2009-03-04 06:31 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-04 06:31:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bastien Nocera 2008-12-12 16:10:01 EST
$ pactl list | grep description | grep USB
device.description = "USB Device 0x46d:0x990 - USB Audio"

Crappy name for a device, the one in lsusb is much better:
$ lsusb | grep QuickCam
Bus 001 Device 003: ID 046d:0990 Logitech, Inc. QuickCam Pro 9000

I know that PA gets the name from ALSA, but maybe that's a case where the name from HAL could be used.
Comment 1 Lennart Poettering 2008-12-15 07:29:09 EST
But how should we decide whether the name from HAl or the name from ALSA is more useful?
Comment 2 Lennart Poettering 2009-02-24 22:46:47 EST
Hmm, I think we could make PA blacklist certain names. However I wonder how an algorithm should look like that gets the lsusb/lspci name from HAL. Just going upwards in the device tree until we find an usb or pci name might be a bit risky because we might end up with strings like "Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1" then.

I'd be happy to add this if there is a reliable algorithm to find this name.
Comment 3 Lennart Poettering 2009-03-04 06:31:00 EST
PA from git will now use the lspci/lsusb name for naming sound cards.

Note You need to log in before you can comment on or make changes to this bug.