Bug 476295 - Uninstalling glibc-headers breaks glibc-devel dependency
Uninstalling glibc-headers breaks glibc-devel dependency
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Andreas Schwab
Fedora Extras Quality Assurance
: 528340 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2008-12-12 16:27 EST by Michael Schwendt
Modified: 2009-10-11 08:18 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-08-20 10:08:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2008-12-12 16:27:22 EST
(originally bug 476275 and closed duplicate of bug 223642)

  $ rpm -qR glibc-devel|grep ^glib
  glibc = 2.9-2
  glibc-headers = 2.9-2

So, glibc-devel requires glibc-headers.

  $ rpm -q --provides glibc-headers
  glibc-headers = 2.9-2
  glibc-headers(x86-32) = 2.9-2

  $ rpm -q --whatprovides glibc-headers

  $ sudo rpm -e glibc-headers

Uh? That should not have been possible, because now:

  $ rpm -V glibc-devel
  Unsatisfied dependencies for glibc-devel-2.9-2.i386:
          glibc-headers = 2.9-2 is needed by glibc-devel-2.9-2.i386

As Seth's message adds, it's "Requires(pre)" for this dependency
on glibc-headers. That's true according to the glibc.spec file.

Bug 223642 explains the RPM semantics and the suggested fix:
"Requires: glibc-headers" in glibc-devel would need to be added to fix this.
Comment 1 Andreas Schwab 2009-08-20 10:08:57 EDT
Fixed in 2.10.90-1.
Comment 2 Matt McCutchen 2009-10-11 08:18:52 EDT
*** Bug 528340 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.