Bug 476303 - Add "noninteractive" flag to HTS runs to allow for quick run of unattended tests
Add "noninteractive" flag to HTS runs to allow for quick run of unattended tests
Status: CLOSED DUPLICATE of bug 659789
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness) (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Greg Nichols
Lawrence Lim
Depends On: 659789
  Show dependency treegraph
Reported: 2008-12-12 17:44 EST by Gary Case
Modified: 2014-03-25 20:55 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2011-04-27 13:36:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Gary Case 2008-12-12 17:44:26 EST
Description of problem:
HTS tests can be divided into two categories: interactive and non-interactive. Engineers often like to run the non-interactive tests before they leave for the day/weekend and come back the next workday to a set of test results. Currently, testers need to disable all interactive tests before a simple 'hts' command can be used to run the rest. It would be helpful if we could add a "noninteractive" (or something like that) flag to the run options to allow for a single quick command to run the unattended tests.
Comment 2 Greg Nichols 2009-11-11 14:53:54 EST
Does "v7 certify --mode auto" cover this?
Comment 3 Gary Case 2009-11-13 17:10:52 EST
If it will automatically skip the interactive tests, that's exactly what we're looking for.
Comment 4 Greg Nichols 2010-01-20 10:05:26 EST
Well, not exactly.  --mode auto will run interactive tests, but these tests will not actually perform all the tests, and these tests will be marked as failures in the results rpm.
Comment 6 Greg Nichols 2010-08-02 14:27:52 EDT
On second though, "v7 certify --mode auto" should perform all non-interactive tests.   These test runs that pass should be valid for certification for non-interactive tests.    That would allow a subsequent invocation of "v7 certify" to pick up a interactive tests (in addition to any failing tests from the first run).

I'll verify this behaviour in v7 1.2.
Comment 10 Greg Nichols 2011-04-27 13:36:09 EDT

*** This bug has been marked as a duplicate of bug 659789 ***

Note You need to log in before you can comment on or make changes to this bug.